]> Pileus Git - grits/blobdiff - src/Makefile.am
destructors, still need to free data in plugins though
[grits] / src / Makefile.am
index fad1033ba25d59d4110d92276b9cfb4eebdcf179..10c83f051789f8f84f4f32a12b604ed1b45ad131 100644 (file)
@@ -5,27 +5,31 @@ bin_PROGRAMS  = aweather wsr88ddec
 BUILT_SOURCES = marshal.c marshal.h
 
 aweather_SOURCES  = main.c \
-       marshal.c        marshal.h        \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-radar-colormap.c           \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
+       marshal.c         marshal.h         \
+       aweather-gui.c    aweather-gui.h    \
+       aweather-view.c   aweather-view.h   \
+       aweather-plugin.c aweather-plugin.h \
+       data.c            data.h            \
+       location.c        location.h        \
+       plugin-radar.c    plugin-radar.h    \
+       plugin-radar-colormap.c             \
+       plugin-ridge.c    plugin-ridge.h    \
+       plugin-example.c  plugin-example.h
 aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
 .list.c:
        glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
 .list.h:
        glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./aweather -d 7
 
 gdb: all
        gdb ./aweather
@@ -38,7 +42,7 @@ memcheck:
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
-                --num-callers=50               \
+                --num-callers=100              \
                 --suppressions=gtk.suppression \
                 ./aweather                     \
-       2> memcheck.log
+       2> valgrind.out