]> Pileus Git - grits/blobdiff - src/Makefile.am
destructors, still need to free data in plugins though
[grits] / src / Makefile.am
index 89408488b632009e423162656474b8fa1dec62b6..10c83f051789f8f84f4f32a12b604ed1b45ad131 100644 (file)
@@ -1,18 +1,48 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather
+AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS  = aweather wsr88ddec
 
-aweather_SOURCES  = \
-       aweather.c       aweather.h       \
-       location.c       location.h       \
-       opengl.c         opengl.h         \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+BUILT_SOURCES = marshal.c marshal.h
 
+aweather_SOURCES  = main.c \
+       marshal.c         marshal.h         \
+       aweather-gui.c    aweather-gui.h    \
+       aweather-view.c   aweather-view.h   \
+       aweather-plugin.c aweather-plugin.h \
+       data.c            data.h            \
+       location.c        location.h        \
+       plugin-radar.c    plugin-radar.h    \
+       plugin-radar-colormap.c             \
+       plugin-ridge.c    plugin-ridge.h    \
+       plugin-example.c  plugin-example.h
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
+
+wsr88ddec         = wsr88ddec.c
+wsr88ddec_LDADD   = -lbz2
+
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
+.list.c:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
+.list.h:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
-       ./aweather
+       ./aweather -d 7
+
+gdb: all
+       gdb ./aweather
+
+ddd: all
+       ddd ./aweather
+
+memcheck:
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=100              \
+                --suppressions=gtk.suppression \
+                ./aweather                     \
+       2> valgrind.out