]> Pileus Git - grits/blobdiff - src/Makefile.am
destructors, still need to free data in plugins though
[grits] / src / Makefile.am
index 8611e504e5a6fb3a983abe66d2d5894fca81e617..10c83f051789f8f84f4f32a12b604ed1b45ad131 100644 (file)
@@ -1,26 +1,35 @@
-AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
-AM_CFLAGS    = -Wall -Werror -Wno-unused --std=gnu99 
-AM_LDFLAGS   = -Wl,--export-dynamic
-bin_PROGRAMS = aweather wsr88ddec
+AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
+AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
+bin_PROGRAMS  = aweather wsr88ddec
+
+BUILT_SOURCES = marshal.c marshal.h
 
 aweather_SOURCES  = main.c \
-       aweather-gui.c   aweather-gui.h   \
-       aweather-view.c  aweather-view.h  \
-       data.c           data.h           \
-       location.c       location.h       \
-       plugin-radar.c   plugin-radar.h   \
-       plugin-radar-colormap.c           \
-       plugin-ridge.c   plugin-ridge.h   \
-       plugin-example.c plugin-example.h
-aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+       marshal.c         marshal.h         \
+       aweather-gui.c    aweather-gui.h    \
+       aweather-view.c   aweather-view.h   \
+       aweather-plugin.c aweather-plugin.h \
+       data.c            data.h            \
+       location.c        location.h        \
+       plugin-radar.c    plugin-radar.h    \
+       plugin-radar-colormap.c             \
+       plugin-ridge.c    plugin-ridge.h    \
+       plugin-example.c  plugin-example.h
+aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
 
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
-# LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
+.list.c:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
+.list.h:
+       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./aweather -d 7
 
 gdb: all
        gdb ./aweather
@@ -33,7 +42,7 @@ memcheck:
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
-                --num-callers=50               \
+                --num-callers=100              \
                 --suppressions=gtk.suppression \
                 ./aweather                     \
-       2> memcheck.log
+       2> valgrind.out