]> Pileus Git - grits/blobdiff - src/Makefile.am
destructors, still need to free data in plugins though
[grits] / src / Makefile.am
index 705df0e19f69ca36897d94b0ad98b5c0246f2ffe..10c83f051789f8f84f4f32a12b604ed1b45ad131 100644 (file)
@@ -20,13 +20,16 @@ aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\""
 wsr88ddec         = wsr88ddec.c
 wsr88ddec_LDADD   = -lbz2
 
+CLEANFILES = gmon.out valgrind.out
+MAINTAINERCLEANFILES = Makefile.in
+
 .list.c:
        glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
 .list.h:
        glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
 
 test: all
-       ./aweather
+       ./aweather -d 7
 
 gdb: all
        gdb ./aweather
@@ -39,7 +42,7 @@ memcheck:
        G_DEBUG=gc-friendly,resident-modules    \
        valgrind --leak-check=full              \
                 --leak-resolution=high         \
-                --num-callers=50               \
+                --num-callers=100              \
                 --suppressions=gtk.suppression \
                 ./aweather                     \
-       2> memcheck.log
+       2> valgrind.out