]> Pileus Git - grits/blobdiff - src/Makefile.am
some site-switching code
[grits] / src / Makefile.am
index ac915429897f12aab6ba1b2074d164268e02ae1b..0a7189e071299bb0f87c8d749ca4c8724c322968 100644 (file)
@@ -3,10 +3,10 @@ AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99
 AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = \
-       aweather.c       aweather.h       \
-       site.c           site.h           \
-       opengl.c         opengl.h         \
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       location.c       location.h       \
        plugin-radar.c   plugin-radar.h   \
        plugin-ridge.c   plugin-ridge.h   \
        plugin-example.c plugin-example.h
@@ -16,3 +16,7 @@ aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
 test: all
        LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
        ./aweather
+
+debug: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       gdb ./aweather