]> Pileus Git - grits/blobdiff - src/Makefile.am
some site-switching code
[grits] / src / Makefile.am
index 7605c8c084af7d72841f1a72497071fc9a201b72..0a7189e071299bb0f87c8d749ca4c8724c322968 100644 (file)
@@ -1,5 +1,22 @@
+AM_CPPFLAGS  = -DDATADIR="\"$(datadir)\"" $(RSL_CFLAGS) $(GTK_CFLAGS) $(CURL_CFLAGS) 
+AM_CFLAGS    = -O3 -Wall -Werror --std=gnu99 
+AM_LDFLAGS   = -Wl,--export-dynamic
 bin_PROGRAMS = aweather
 
-aweather_SOURCES  = aweather.c
-aweather_CPPFLAGS = @PACKAGE_CFLAGS@
-aweather_LDADD    = @PACKAGE_LIBS@
+aweather_SOURCES  = main.c \
+       aweather-gui.c   aweather-gui.h   \
+       aweather-view.c  aweather-view.h  \
+       location.c       location.h       \
+       plugin-radar.c   plugin-radar.h   \
+       plugin-ridge.c   plugin-ridge.h   \
+       plugin-example.c plugin-example.h
+aweather_LDADD    = $(RSL_LIBS) $(GTK_LIBS) $(CURL_LIBS)
+
+
+test: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       ./aweather
+
+debug: all
+       LD_LIBRARY_PATH=/usr/local/trmm/GVBOX/lib/ \
+       gdb ./aweather