]> Pileus Git - ~andy/sunrise/blobdiff - x11-libs/libqglviewer/libqglviewer-2.3.1.ebuild
x11-libs/libqglviewer/: Fix qt deps
[~andy/sunrise] / x11-libs / libqglviewer / libqglviewer-2.3.1.ebuild
index c5f129924eed49f03bd3b64387c79be477704402..5431cbb970459e9cdbc3c442f83af7d8772e6af8 100644 (file)
@@ -1,10 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit qt4
+EAPI="2"
 
-MY_P="libQGLViewer-"${PV}
+inherit qt4-r2
+
+MY_P="libQGLViewer-${PV}"
 
 DESCRIPTION="Simple 3D viewer class for Qt OpenGL applications"
 HOMEPAGE="http://www.libqglviewer.com"
@@ -16,10 +18,15 @@ KEYWORDS="~amd64 ~x86"
 IUSE="doc"
 
 DEPEND="virtual/opengl
-       >=x11-libs/qt-4.3"
+       dev-libs/qtgui:4"
+RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}/QGLViewer
 
+src_configure() {
+       true
+}
+
 src_compile() {
        eqmake4 QGLViewer.pro -o Makefile PREFIX=/usr
        emake || die "emake QGLViewer failed"
@@ -41,7 +48,7 @@ src_install() {
 
        if use doc ; then
                dohtml -r ../doc/* || die "installing html files failed"
-               insinto /usr/share/doc/${PF}
-               doins -r ../examples || die "installing examples failed"
+               docinto examples
+               dodoc ../examples/* || die "installing examples failed"
        fi
 }