]> Pileus Git - ~andy/sunrise/blobdiff - sci-libs/rsl/rsl-1.43.ebuild
sci-libs/rsl: Update to RSL 1.43
[~andy/sunrise] / sci-libs / rsl / rsl-1.43.ebuild
similarity index 70%
rename from sci-libs/rsl/rsl-1.41.ebuild
rename to sci-libs/rsl/rsl-1.43.ebuild
index 5d950bd03416f31ba1d7541bd9dc94ee5eb69127..a4a7d25d8e4d9b4d60620535b17757d65ab602e6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -15,15 +15,18 @@ SRC_URI="ftp://trmm-fc.gsfc.nasa.gov/software/${MY_P}.tar.gz"
 LICENSE="LGPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="hdf"
 
-RDEPEND="sci-libs/hdf
-       virtual/jpeg"
+RDEPEND="hdf? ( sci-libs/hdf )"
 DEPEND="${RDEPEND}"
 
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
-       epatch "${FILESDIR}/${PN}-automake.patch"
+       epatch "${FILESDIR}/${PN}-"{automake,with_hdf}".patch"
        eautoreconf
 }
+
+src_configure() {
+       econf $(use_with hdf)
+}