]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Add gps USE flag
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
index 780543da04eee32535adebcba6da7d3a28fee86d..ed448dd85662ad471e486e12a8dccffde91f08ce 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -15,11 +15,17 @@ SRC_URI=""
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
+IUSE="gps"
 
 RDEPEND="~sci-libs/grits-9999
        x11-libs/gtk+:2
-       sci-libs/rsl"
+       sci-libs/rsl
+       gps? ( >=sci-geosciences/gpsd-3 )"
 DEPEND="${RDEPEND}"
 
 DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+       G2CONF="${G2CONF}
+               $(use_enable gps)"
+}