]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
index 7064ec89ca55a2ef981b61d369801775930f5026..5b5b419c75e03524883796b4c66a4056eec51266 100644 (file)
@@ -1,27 +1,31 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EGIT_REPO_URI="git://lug.rose-hulman.edu/proj/aweather"
+EAPI=4
+EGIT_REPO_URI="git://pileus.org/aweather"
 EGIT_BOOTSTRAP="eautoreconf"
 
-inherit autotools git
+inherit autotools gnome2 git-2
 
 DESCRIPTION="A weather monitoring program"
-HOMEPAGE="http://lug.rose-hulman.edu/wiki/AWeather"
+HOMEPAGE="http://pileus.org/aweather"
 SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
+IUSE="gps"
 
-RDEPEND="~sci-libs/libgis-9999
-       >=x11-libs/gtk+-2.16
-       sci-libs/rsl"
+RDEPEND="~sci-libs/grits-9999
+       x11-libs/gtk+:2
+       sci-libs/rsl
+       gps? ( >=sci-geosciences/gpsd-3 )"
 DEPEND="${RDEPEND}"
 
-src_install() {
-       emake DESTDIR="${D}" install || die "install failed"
-       dodoc ChangeLog README TODO || die
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+       G2CONF="${G2CONF}
+               $(use_enable gps)"
 }