]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
index 55277a23096c1fbb3ee01321f3f3a9025658c382..5b5b419c75e03524883796b4c66a4056eec51266 100644 (file)
@@ -1,25 +1,31 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EGIT_REPO_URI="git://lug.rose-hulman.edu/proj/aweather"
+EAPI=4
+EGIT_REPO_URI="git://pileus.org/aweather"
 EGIT_BOOTSTRAP="eautoreconf"
 
-EAPI=4
-inherit gnome2 git-2
+inherit autotools gnome2 git-2
 
 DESCRIPTION="A weather monitoring program"
-HOMEPAGE="http://lug.rose-hulman.edu/proj/aweather"
+HOMEPAGE="http://pileus.org/aweather"
 SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
+IUSE="gps"
 
 RDEPEND="~sci-libs/grits-9999
        x11-libs/gtk+:2
-       sci-libs/rsl"
+       sci-libs/rsl
+       gps? ( >=sci-geosciences/gpsd-3 )"
 DEPEND="${RDEPEND}"
 
 DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+       G2CONF="${G2CONF}
+               $(use_enable gps)"
+}