]> Pileus Git - ~andy/sunrise/blobdiff - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
index 0ff004213be8f89969ffc496304769698765a7c7..5b5b419c75e03524883796b4c66a4056eec51266 100644 (file)
@@ -1,34 +1,31 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit autotools gnome2 subversion
+EAPI=4
+EGIT_REPO_URI="git://pileus.org/aweather"
+EGIT_BOOTSTRAP="eautoreconf"
+
+inherit autotools gnome2 git-2
 
 DESCRIPTION="A weather monitoring program"
-HOMEPAGE="http://lug.rose-hulman.edu/wiki/AWeather"
+HOMEPAGE="http://pileus.org/aweather"
 SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE="doc"
-
-RDEPEND=">=net-libs/libsoup-2.26
-       >=x11-libs/gtk+-2.16
-       x11-libs/gtkglext
-       sci-libs/rsl"
+IUSE="gps"
 
-# gtk-doc-am needed to eautoreconf
-DEPEND="${RDEPEND}
-       dev-util/gtk-doc-am
-       doc? ( dev-util/gtk-doc )"
+RDEPEND="~sci-libs/grits-9999
+       x11-libs/gtk+:2
+       sci-libs/rsl
+       gps? ( >=sci-geosciences/gpsd-3 )"
+DEPEND="${RDEPEND}"
 
 DOCS="ChangeLog README TODO"
 
-# Fix for gtk-doc bug
-MAKEOPTS="${MAKEOPTS} -j1"
-
-ESVN_REPO_URI="https://lug.rose-hulman.edu/svn/proj-aweather/trunk"
-# Tell SVN to accept the self-signed certificate from the server
-ESVN_OPTIONS="--non-interactive --trust-server-cert"
-ESVN_BOOTSTRAP="gtkdocize && eautoreconf"
+pkg_setup() {
+       G2CONF="${G2CONF}
+               $(use_enable gps)"
+}