]> Pileus Git - ~andy/sunrise/blobdiff - sci-chemistry/hoomd/hoomd-0.9.1.3815.ebuild
sci-chemistry/hoomd: Fixed unescaped characters in pkg_setup
[~andy/sunrise] / sci-chemistry / hoomd / hoomd-0.9.1.3815.ebuild
index c7f90522459971e4cfd0fee99a0c3396a6937b9c..6da086d3c0eee84061eb9fbafcdba15d238ce045 100644 (file)
@@ -29,14 +29,14 @@ pkg_setup() {
        python_pkg_setup
 
        if use cuda; then
-               if has_version <=nvidia-cuda-toolkit-3.0; then
+               if has_version '<=dev-util/nvidia-cuda-toolkit-3.0'; then
                        if version_is_at_least 4.4 $(gcc-version); then
                                ewarn "Nvidia CUDA SDK version 3.0 and below requires a gcc version less than 4.4"
                                ewarn "Enabling the cuda use flag with gcc version 4.4 or higher will cause build failures in those SDK versions."
                                ewarn "Please use gcc-config to set a gcc version less than 4.4 ."
                        fi
 
-               elif has_version <=nvidia-cuda-toolkit-3.2; then
+               elif has_version '<=dev-util/nvidia-cuda-toolkit-3.2'; then
                        if version_is_at_least 4.5 $(gcc-version); then
                                ewarn "Nvidia CUDA SDK Version 3.2 and below require a gcc version less than 4.5"
                                ewarn "Enabling the cuda use flag with gcc version 4.5 or higher will cause build failures in those SDK versions."