]> Pileus Git - ~andy/sunrise/blobdiff - net-misc/wolman/wolman-9999.ebuild
net-misc/wolman: Properly fix qt deps
[~andy/sunrise] / net-misc / wolman / wolman-9999.ebuild
index cf0ac365b84f994b923cc307bde5b7e426c8364c..8b0cfacab5a4932cd30708a19842765141e35ae6 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="1"
-inherit qt4 subversion eutils
+EAPI="2"
+inherit qt4-r2 subversion eutils
 
 QT4_BUILT_WITH_USE_CHECK="png"
 
@@ -17,7 +17,7 @@ SLOT="0"
 KEYWORDS=""
 IUSE=""
 
-DEPEND="x11-libs/qt-gui:4
+DEPEND="dev-qt/qtgui:4
        net-libs/libnet
        net-libs/libpcap"
 RDEPEND="${DEPEND}
@@ -25,11 +25,6 @@ RDEPEND="${DEPEND}
 
 S="${WORKDIR}/${PN}"
 
-src_compile() {
-       eqmake4
-       emake || die "make failed"
-}
-
 src_install() {
        dosbin wolman || die "dosbin failed"
        newicon gfx/green.png ${PN}.png