]> Pileus Git - ~andy/sunrise/blobdiff - media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
media-gfx/fontmatrix: Properly fix qt deps
[~andy/sunrise] / media-gfx / fontmatrix / fontmatrix-0.6.0.ebuild
index 0e5fc6a6c35339d89f80c9f0fe011db3b2b5b1ef..70df3121e9fcdedf077d99451840c0abe32e413e 100644 (file)
@@ -1,23 +1,25 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="2"
+EAPI=4
 
-inherit qt4 cmake-utils
+inherit qt4-r2 cmake-utils
 
 DESCRIPTION="A font manager"
-HOMEPAGE="http://www.fontmatrix.net/"
-SRC_URI="http://www.fontmatrix.net/archives/${P}-Source.tar.gz"
+HOMEPAGE="http://oep-h.com/fontmatrix/"
+# old link dead, no official one yet ( Mar 21 2012 )
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${P}-Source.tar.gz/6a00c9448a50d3bab5acb4145f778f2d/${P}-Source.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="debug"
 
-RDEPEND="x11-libs/qt-gui:4
-       x11-libs/qt-svg:4
-       x11-libs/qt-webkit:4
+RDEPEND="dev-qt/qtgui:4
+       dev-qt/qtsql:4
+       dev-qt/qtsvg:4
+       dev-qt/qtwebkit:4
        media-libs/freetype:2"
 DEPEND=${RPEDEND}
 
@@ -29,15 +31,16 @@ src_configure() {
 }
 
 src_install() {
-       dobin "${CMAKE_BUILD_DIR}"/src/${PN} || die
-       doman ${PN}.1 || die
-       domenu ${PN}.desktop || die
-       dodoc ChangeLog TODO || die
+       dobin "${CMAKE_BUILD_DIR}"/src/${PN}
+       doman ${PN}.1
+       domenu ${PN}.desktop
+       doicon ${PN}.png
+       dodoc ChangeLog TODO
 }
 
 pkg_postinst() {
        elog "If you encounter problems or just have questions or if you have"
-       elog " suggestions, please take time to suscribe to the undertype-users"
-       elog " mailing list ( https://mail.gna.org/listinfo/undertype-users )."
-       elog " If you want to reach us quickly, come to #fontmatrix at Freenode."
+       elog "suggestions, please take time to suscribe to the undertype-users"
+       elog "mailing list ( https://mail.gna.org/listinfo/undertype-users )."
+       elog "If you want to reach us quickly, come to #fontmatrix at Freenode."
 }