]> Pileus Git - ~andy/sunrise/blobdiff - games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild
games-misc/limbs-off: Add alpha1 and fix various issues with 9999
[~andy/sunrise] / games-misc / limbs-off / limbs-off-1.0_alpha1.ebuild
diff --git a/games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild b/games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild
new file mode 100644 (file)
index 0000000..951d972
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit autotools git-2 games
+
+DESCRIPTION="Gratis Free Software fighting game"
+HOMEPAGE="http://plaimi.net/games/"
+EGIT_REPO_URI="https://github.com/stiell/${PN}.git
+    git://github.com/stiell/${PN}.git"
+EGIT_COMMIT="5cb4434e89e945d215e1f9b12ffc6e998c3367e5"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+       media-libs/fontconfig
+       media-libs/libpng:0
+       media-libs/libsdl
+       media-libs/sdl-ttf
+       virtual/opengl
+       "
+
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       "
+
+src_unpack() {
+       git-2_src_unpack
+}
+
+src_prepare() {
+       eautoreconf
+}
+
+src_configure() {
+       egamesconf \
+               --with-icondir=/usr/share/pixmaps \
+               --with-desktopdir=/usr/share/applications
+}
+
+src_install() {
+       dodoc HACKING TODO || die
+       emake DESTDIR="${D}" install || die
+       prepgamesdirs
+}