]> Pileus Git - ~andy/sunrise/blobdiff - games-emulation/gr-lida/gr-lida-0.7.1.ebuild
games-emulation/gr-lida: Properly fix qt deps
[~andy/sunrise] / games-emulation / gr-lida / gr-lida-0.7.1.ebuild
index 2144d4448c485c68dd36b8f729d783e874470171..df111b8424541358e0cb223c188d47d0af5aa3f3 100644 (file)
@@ -1,9 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="1"
-inherit qt4
+EAPI="2"
+
+inherit qt4-r2
 
 MY_P="GR-lida-${PV}"
 
@@ -16,24 +17,14 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="dosbox scummvm"
 
-DEPEND="|| ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-sql:4 )
-       =x11-libs/qt-4.3*:4 )
+DEPEND="dev-qt/qtgui:4
+       dev-qt/qtsql:4[sqlite]
        dosbox? ( games-emulation/dosbox )
        scummvm? ( games-engines/scummvm )"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
 
-QT4_BUILT_WITH_USE_CHECK="gif jpeg png sqlite3"
 S=${WORKDIR}/${MY_P}
 
-src_compile(){
-       eqmake4 "${PN}".pro
-       emake || die "Compile Failed"
-}
-
-src_install(){
-       emake INSTALL_ROOT="${D}" install || die "Install Failed"
-}
-
 pkg_postinst(){
        elog "The GUI is by default in Spanish."
        elog "If you need it, English is available on the Options Menu."