]> Pileus Git - ~andy/sunrise/blobdiff - games-arcade/vodovod/vodovod-1.10.ebuild
games-arcade/vodovod: Add suggested RDEPEND=${DEPEND}, add die statements
[~andy/sunrise] / games-arcade / vodovod / vodovod-1.10.ebuild
index c1e5e47b9426d8d7e848526feed31bbc446b834e..243d0402879391935f0cef6d5f080e4e64e7abcf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -6,9 +6,9 @@ inherit eutils games
 
 DESCRIPTION="A free cross-platform pipe connecting game"
 HOMEPAGE="http://home.gna.org/vodovod/"
-SRC_URI="http://download.gna.org/vodovod/${P}-src.tar.gz"
+SRC_URI="http://download.gna.org/${PN}/${P}-src.tar.gz"
 
-S="${WORKDIR}/${P}-src"
+S=${WORKDIR}/${P}-src
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~x86"
@@ -17,11 +17,12 @@ IUSE=""
 DEPEND="media-libs/libsdl
                media-libs/sdl-mixer
                media-libs/sdl-image"
+RDEPEND=${DEPEND}
 
 src_unpack() {
        unpack ${A}
        cd "${S}"
-       sed -e 's:"\(data/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i *.cpp
+       sed -e 's:"\(data/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i *.cpp || die
 }
 
 src_install() {