]> Pileus Git - ~andy/sunrise/blobdiff - dev-util/serial-io/serial-io-1.0.ebuild
dev-util/serial-io: Properly fix qt deps
[~andy/sunrise] / dev-util / serial-io / serial-io-1.0.ebuild
index 582b2c97c304d91c885b4f9af4ec7a1c8c4d0a8c..94ae6c7713f445c5c28047420a91a8616ea32443 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="1"
+EAPI="2"
 
-inherit qt4
+inherit qt4-r2
 
 DESCRIPTION="A simple program to send and receive data to and from a serial device."
 HOMEPAGE="http://www.sourceforge.net/projects/serial-io/"
@@ -15,19 +15,10 @@ SLOT="0"
 KEYWORDS="~x86"
 IUSE=""
 
-DEPEND="x11-libs/qt-gui:4
+DEPEND="dev-qt/qtgui:4
        dev-libs/libserial"
 RDEPEND="${DEPEND}"
 
-S="${WORKDIR}/${PN}"
-
-src_compile() {
-       eqmake4
-       emake || die "emake failed"
-}
+DOCS="TODO"
 
-src_install() {
-       emake INSTALL_ROOT="${D}" install || die "emake install failed"
-
-       dodoc TODO || die "Failed to install TODO file!"
-}
+S="${WORKDIR}/${PN}"