]> Pileus Git - ~andy/sunrise/blobdiff - dev-db/sql2class/sql2class-1.9.2.ebuild
dev-db/sql2class: Adding ~amd64 keyword
[~andy/sunrise] / dev-db / sql2class / sql2class-1.9.2.ebuild
index 4b9cbe7b738d6ff040009b6774f9f072854c5c84..ead92b2428aa92e5e60095bd0152196c7a42d131 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 inherit eutils toolchain-funcs
 
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 
 DESCRIPTION="SQL C++ code generator (to use with dev-db/*wrapped packages)"
 HOMEPAGE="http://www.alhem.net/project/sql2class/index.html"
@@ -14,8 +14,7 @@ SLOT="0"
 IUSE="mysql sqlite"
 
 DEPEND=""
-RDEPEND="mysql? ( dev-db/mysqlwrapped )
-               sqlite? ( dev-db/sqlitewrapped )"
+RDEPEND=""
 
 src_unpack() {
        unpack ${A}
@@ -30,7 +29,7 @@ src_unpack() {
 }
 
 src_compile() {
-       emake CXX=$(tc-getCXX) || die "emake failed"
+       emake CXX="$(tc-getCXX)" || die "emake failed"
 }
 
 src_install() {