]> Pileus Git - ~andy/sunrise/blobdiff - dev-cpp/mpfrc++/mpfrc++-20120116.ebuild
dev-cpp/mpfrc++: New ebuild for bug #412249 thanks to hasufell and floppym
[~andy/sunrise] / dev-cpp / mpfrc++ / mpfrc++-20120116.ebuild
diff --git a/dev-cpp/mpfrc++/mpfrc++-20120116.ebuild b/dev-cpp/mpfrc++/mpfrc++-20120116.ebuild
new file mode 100644 (file)
index 0000000..1e1d619
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib toolchain-funcs vcs-snapshot
+
+DESCRIPTION="High-performance C++ interface for MPFR library"
+HOMEPAGE="http://www.holoborodko.com/pavel/mpfr/"
+SRC_URI="https://bitbucket.org/advanpix/nika/get/88fa1ed2a7a5.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/mpfr"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       cp "${FILESDIR}/Makefile" Makefile || die
+}
+
+src_compile() {
+       emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+       dolib.so lib${PN}.so.${PV}
+       dosym lib${PN}.so.${PV} usr/$(get_libdir)/lib${PN}.so
+       insinto usr/include
+       doins dlmalloc.h mpreal.h
+}