]> Pileus Git - ~andy/sunrise/blobdiff - app-misc/japanese-vocabulary/japanese-vocabulary-0.6.ebuild
app-misc/japanese-vocabulary: Adding ~amd64 keyword, fixing qt deps properly
[~andy/sunrise] / app-misc / japanese-vocabulary / japanese-vocabulary-0.6.ebuild
index 78cbe975d2e3bda099fc7b465b1e7c4c2e13f21e..26340f4faf87bd9039a54f09b9271c360646119b 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="1"
-inherit eutils qt4 toolchain-funcs
+EAPI="2"
+inherit eutils qt4-r2 toolchain-funcs
 
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 
 MY_PN=JapaneseVocabulary
 
@@ -16,17 +16,12 @@ LICENSE="GPL-2"
 SLOT="0"
 IUSE=""
 
-DEPEND=">=x11-libs/qt-4.2:4"
+DEPEND="dev-qt/qtgui:4
+       dev-qt/qtsql:4[sqlite]"
 RDEPEND="${DEPEND}"
 
-QT4_BUILT_WITH_USE_CHECK="sqlite3"
 S=${WORKDIR}/${PN}
 
-src_compile() {
-       eqmake4 ${MY_PN}.pro
-       emake || die "emake failed"
-}
-
 src_install() {
        dobin ${MY_PN}
        keepdir /usr/share/${PN}
@@ -46,5 +41,7 @@ pkg_config() {
 
 pkg_postrm() {
        # do not leave orphaned cruft behind
-       [[ -e ${ROOT}/usr/share/${PN} ]] && rm -rf /usr/share/${PN}
+       if ! has_version ${CATEGORY}/${PN} ; then
+               [[ -d ${ROOT}/usr/share/${PN} ]] && rm -rf "${ROOT}"/usr/share/${PN}
+       fi
 }