]> Pileus Git - ~andy/sunrise/blobdiff - app-dicts/words-bin/words-bin-1.97.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / app-dicts / words-bin / words-bin-1.97.ebuild
index 6eb65b2bec3da7883cbb744b5df1621950c89ec1..63173fa19d04641e14b3a8fe6259c1548874ed0e 100644 (file)
@@ -1,26 +1,24 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 inherit eutils
 
-MY_P="${P/-bin}"
+MY_P="${P/-bin}Ed"
 
-DESCRIPTION="Latin-English dictionary."
+DESCRIPTION="Latin--English dictionary."
 HOMEPAGE="http://users.erols.com/whitaker/words.htm"
 SRC_URI="http://atrey.karlin.mff.cuni.cz/~sanda/mirror/${MY_P}-linux.tar.gz"
-#SRC_URI="ftp://petrus.thomasaquinas.edu/pub/linux/words/${MY_P}-linux.tar.gz"
-#Reported problems with downloading
 
 SLOT="0"
 LICENSE="words"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 
 IUSE=""
 DEPEND=""
 RDEPEND=""
 
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
 
 src_unpack(){
        unpack ${A}
@@ -30,11 +28,10 @@ src_unpack(){
 
 src_install() {
        insinto /opt/${MY_P}
-       dodir /usr/bin
        dodoc wordsdoc*
        rm wordsdoc*
        doins *
-       dosym "${D}"/opt/${MY_P}/latin /usr/bin/latin
+       dosym /opt/${MY_P}/latin /usr/bin/latin
        fperms 755 /opt/${MY_P}/{latin,words}
 }