]> Pileus Git - ~andy/sunrise/blobdiff - app-admin/ldapscripts/ldapscripts-1.5-r1.ebuild
app-admin/ldapscripts: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-admin / ldapscripts / ldapscripts-1.5-r1.ebuild
similarity index 90%
rename from app-admin/ldapscripts/ldapscripts-1.5.ebuild
rename to app-admin/ldapscripts/ldapscripts-1.5-r1.ebuild
index 48187544717e04cd8e39bc1cd70494653c473f9a..feb748a8a9ba65b1f840b1137bf306b5c2281dc3 100644 (file)
@@ -2,6 +2,10 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI="5"
+
+inherit eutils
+
 DESCRIPTION="Shell scripts to manage POSIX accounts in an LDAP."
 HOMEPAGE="http://contribs.martymac.com/"
 SRC_URI="http://contribs.martymac.com/${PN}/${P}.tgz"
@@ -20,11 +24,7 @@ RUNTIMEFILE="runtime"
 ETCDIR="/etc/${PN}"
 ETCFILE="ldapscripts.conf"
 
-src_unpack() {
-       unpack ${A}
-
-       # Prepare sources, as the install script would do it
-       cd "${S}"
+src_prepare() {
        sed -i.orig -e "s|^_RUNTIMEFILE=.*|_RUNTIMEFILE=\"${RUNTIMEDIR}/${RUNTIMEFILE}\"|g" bin/*
        sed -i.orig -e "s|^_CONFIGFILE=.*|_CONFIGFILE=\"${ETCDIR}/${ETCFILE}\"|g" etc/*
 }