]> Pileus Git - ~andy/sunrise/blobdiff - app-admin/jailkit/jailkit-2.10.ebuild
app-admin/jailkit: Adding ~amd64 keyword
[~andy/sunrise] / app-admin / jailkit / jailkit-2.10.ebuild
index 2a46e698bc67747d431830a70bbce3703c3f6b3a..e8bffdaf60c1a0369a1ee815088ed3a9344f3400 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -12,26 +12,25 @@ SRC_URI="http://olivier.sessink.nl/${PN}/${P}.tar.bz2"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 src_prepare() {
        epatch \
                "${FILESDIR}/${P}-ldflags.patch" \
-               "${FILESDIR}/${P}-pyc.patch"
+               "${FILESDIR}/${P}-pyc.patch" \
+               "${FILESDIR}/${P}-noshells.patch"
        eautoreconf
 }
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       doinitd "${FILESDIR}/jailkit"
+       doinitd "${FILESDIR}/jailkit" ||  die "doinit install failed"
 }
 
 pkg_postinst() {
-       elog "Don't forget to add /usr/sbin/jk_chrootsh to /etc/shells."
-}
-
-pkg_postrm() {
-       elog "If you want to keep your system clean, don't forget to remove"
-       elog "the line containing /usr/sbin/jk_chrootsh from /etc/shells."
+       ebegin "Updating /etc/shells"
+       { grep -v "^/usr/sbin/jk_chrootsh$" "${ROOT}"etc/shells; echo "/usr/sbin/jk_chrootsh"; } > "${T}"/shells
+       mv -f "${T}"/shells "${ROOT}"etc/shells
+       eend $?
 }