]> Pileus Git - ~andy/sunrise/blobdiff - app-admin/jailkit/jailkit-2.10.ebuild
app-admin/jailkit: Adding ~amd64 keyword
[~andy/sunrise] / app-admin / jailkit / jailkit-2.10.ebuild
index 20ffae774d5b05a4bd12589f00ace1378d3ac214..e8bffdaf60c1a0369a1ee815088ed3a9344f3400 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -12,7 +12,7 @@ SRC_URI="http://olivier.sessink.nl/${PN}/${P}.tar.bz2"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 src_prepare() {
@@ -25,12 +25,12 @@ src_prepare() {
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       doinitd "${FILESDIR}/jailkit"
+       doinitd "${FILESDIR}/jailkit" ||  die "doinit install failed"
 }
 
 pkg_postinst() {
        ebegin "Updating /etc/shells"
-       ( grep -v "^/usr/sbin/jk_chroots$" "${ROOT}"etc/shells; echo "/usr/sbin/jk_chroots" ) > "${T}"/shells
+       { grep -v "^/usr/sbin/jk_chrootsh$" "${ROOT}"etc/shells; echo "/usr/sbin/jk_chrootsh"; } > "${T}"/shells
        mv -f "${T}"/shells "${ROOT}"etc/shells
        eend $?
 }