]> Pileus Git - ~andy/rsl/blobdiff - src/Makefile.am
Cleanup autotools files
[~andy/rsl] / src / Makefile.am
index be63fbaa41e91b977c571d36ee3acf8ed2297201..e37d4d243c5b6ff20fa271777f32501912827187 100644 (file)
@@ -1,49 +1,41 @@
-## Process w/ automake.  Or, autoreconf; make ##
-AM_CFLAGS = -DDATADIR="\"$(datadir)/rsl\""
-AUTOMAKE_OPTIONS = foreign
-SUBDIRS = . colors doc examples
-INCLUDES = -I. -I$(srcdir) -I$(prefix)/include -I$(prefix)/toolkit/include
+AM_CPPFLAGS = -I. -I..
+AM_YFLAGS = -d
 
 lib_LTLIBRARIES = librsl.la
 
-wsr88ddir = $(datadir)/rsl/
-dist_wsr88d_DATA = wsr88d_locations.dat
-
 include_HEADERS = rsl.h toolkit_1BC-51_appl.h
 
 headers = africa.h dorade.h lassen.h \
-          mcgill.h nsig.h radtec.h rainbow.h \
-          rapic_routines.h toga.h \
-          wsr88d.h \
+         mcgill.h nsig.h radtec.h rainbow.h \
+         rapic_routines.h toga.h \
+         wsr88d.h \
          $(include_HEADERS)
 
-librsl_la_LDFLAGS = -version-info 1:41
-librsl_la_SOURCES = \
-    $(rapic_c) $(radtec_c) \
-    dorade.c dorade_print.c dorade_to_radar.c \
-    lassen.c lassen_to_radar.c \
-    edge_to_radar.c \
-    radar.c volume.c image_gen.c cappi.c fraction.c read_write.c farea.c \
-    range.c radar_to_uf.c uf_to_radar.c wsr88d_to_radar.c \
-    carpi.c cube.c sort_rays.c toga_to_radar.c gts.c histogram.c \
-    ray_indexes.c anyformat_to_radar.c get_win.c endian.c mcgill_to_radar.c \
-    mcgill.c interp.c toga.c wsr88d.c wsr88d_get_site.c wsr88d_m31.c \
-    gzip.c prune.c reverse.c fix_headers.c \
-    nsig_to_radar.c nsig.c nsig2_to_radar.c \
-    africa_to_radar.c africa.c \
-    radar_to_hdf_2.c hdf_to_radar.c toolkit_memory_mgt.c \
-    radar_to_hdf_1.c rainbow.c rainbow_to_radar.c $(headers)
-
-
-rapic_c =  rapic_to_radar.c rapic.y rapic-lex.l rapic_routines.c
-radtec_c = radtec_to_radar.c radtec.c
-
-
-PREFIX = rapic
-LFLAGS = -P$(PREFIX)
-YFLAGS = -d -p $(PREFIX)
-LEX_OUTPUT_ROOT = lex.$(PREFIX)
-
-EXTRA_DIST = CHANGES CHECK_LIST Copyright GPL LGPL wsr88d_locations.dat rapic.h
-
-DISTCLEANFILES = rapic.c rapic-lex.c
+librsl_la_LDFLAGS  = -version-info 1:41
+librsl_la_CPPFLAGS = -DDATADIR="\"$(datadir)/rsl\"" 
+librsl_la_SOURCES  = \
+       rapic_parse.y rapic_scan.l rapic_to_radar.c rapic_routines.c \
+       radtec.c radtec_to_radar.c \
+       dorade.c dorade_print.c dorade_to_radar.c \
+       lassen.c lassen_to_radar.c \
+       edge_to_radar.c \
+       radar.c volume.c image_gen.c cappi.c fraction.c read_write.c farea.c \
+       range.c radar_to_uf.c uf_to_radar.c wsr88d_to_radar.c \
+       carpi.c cube.c sort_rays.c toga_to_radar.c gts.c histogram.c \
+       ray_indexes.c anyformat_to_radar.c get_win.c endian.c mcgill_to_radar.c \
+       mcgill.c interp.c toga.c wsr88d.c wsr88d_get_site.c wsr88d_m31.c \
+       gzip.c prune.c reverse.c fix_headers.c \
+       nsig_to_radar.c nsig.c nsig2_to_radar.c \
+       africa_to_radar.c africa.c \
+       radar_to_hdf_2.c hdf_to_radar.c toolkit_memory_mgt.c \
+       radar_to_hdf_1.c rainbow.c rainbow_to_radar.c $(headers)
+
+# This should be speciifc to rapic,
+# but I'm not sure how to do that with autofoo
+AM_LFLAGS  = -P rapic
+AM_YFLAGS += -p rapic
+LEX_OUTPUT_ROOT = lex.rapic
+
+BUILT_SOURCES = rapic_parse.h
+
+DISTCLEANFILES = rapic_scan.c rapic_parse.c