]> Pileus Git - ~andy/rsl/blobdiff - src/Makefile.am
Relative build for non-win32
[~andy/rsl] / src / Makefile.am
index d333a37ead5bb22e78a77e950793934484a97f2c..8542bf6c75112f12bfbb216655d7ca25552e5a26 100644 (file)
@@ -1,4 +1,4 @@
-AM_CPPFLAGS = -I. -I..
+M_CPPFLAGS = -I. -I..
 AM_YFLAGS = -d
 
 lib_LTLIBRARIES = librsl.la
@@ -12,7 +12,7 @@ headers = africa.h dorade.h lassen.h \
          $(include_HEADERS)
 
 librsl_la_LDFLAGS  = -version-info 1:42
-librsl_la_CPPFLAGS = -DDATADIRRSL="\"$(dots)$(datadir)/rsl1\""
+librsl_la_CPPFLAGS = -DDATADIRRSL="\"$(DOTS)$(datadir)/rsl1\""
 librsl_la_SOURCES  = \
        rapic_parse.y rapic_scan.l rapic_to_radar.c rapic_routines.c \
        radtec.c radtec_to_radar.c \
@@ -29,11 +29,10 @@ librsl_la_SOURCES  = \
        radar_to_hdf_2.c hdf_to_radar.c toolkit_memory_mgt.c \
        radar_to_hdf_1.c rainbow.c rainbow_to_radar.c $(headers)
 
-if WIN32
+if SYS_WIN
 librsl_la_LDFLAGS += -mwindows -no-undefined
 librsl_la_LIBADD   = -lws2_32
 librsl_la_SOURCES += gzip_win32.c 
-dots               = ..
 else
 librsl_la_SOURCES += gzip.c 
 endif