]> Pileus Git - ~andy/gtk/blobdiff - tests/Makefile.am
stylecontext: Do invalidation on first resize container
[~andy/gtk] / tests / Makefile.am
index 567e46ca8c52cb540b62cbb69a548bab7bdec551..143f8e481fc3d99a36728de36d8d9acd1e558c6f 100644 (file)
@@ -25,9 +25,12 @@ testsocket_programs = testsocket testsocket_child
 endif
 
 noinst_PROGRAMS =  $(TEST_PROGS)       \
+       animated-resizing               \
+       motion-compression              \
        simple                          \
        flicker                         \
        print-editor                    \
+       video-timer                     \
        testaccel                       \
        testadjustsize                  \
        testappchooser                  \
@@ -54,6 +57,7 @@ noinst_PROGRAMS =  $(TEST_PROGS)      \
        testfontchooser                 \
        testfontchooserdialog           \
        testframe                       \
+       testfullscreen                  \
        testgeometry                    \
        testgiconpixbuf                 \
        testgrid                        \
@@ -148,9 +152,12 @@ endif
 
 endif
 
+animated_resizing_DEPENDENCIES = $(TEST_DEPS)
 flicker_DEPENDENCIES = $(TEST_DEPS)
+motion_compression_DEPENDENCIES = $(TEST_DEPS)
 simple_DEPENDENCIES = $(TEST_DEPS)
 print_editor_DEPENDENCIES = $(TEST_DEPS)
+video_timer_DEPENDENCIES = $(TEST_DEPS)
 testheightforwidth_DEPENDENCIES = $(TEST_DEPS)
 testicontheme_DEPENDENCIES = $(TEST_DEPS)
 testiconview_DEPENDENCIES = $(TEST_DEPS)
@@ -248,6 +255,16 @@ testpixbuf_scale_DEPENDENCIES = $(TEST_DEPS)
 testgmenu_DEPENDENCIES = $(TEST_DEPS)
 testlogout_DEPENDENCIES = $(TEST_DEPS)
 
+animated_resizing_SOURCES =    \
+       animated-resizing.c     \
+       variable.c              \
+       variable.h
+
+video_timer_SOURCES =  \
+       video-timer.c   \
+       variable.c      \
+       variable.h
+
 testboxcss_SOURCES =   \
        testboxcss.c    \
        prop-editor.c