]> Pileus Git - ~andy/gtk/blobdiff - modules/engines/ms-windows/Makefile.am
Use AM_CPPFLAGS instead the obsolete INCLUDES
[~andy/gtk] / modules / engines / ms-windows / Makefile.am
index 0644ba27ada9722c1c09792c54f850d573bea1fd..fd0a40e480e018df9dde436a4f9cc4435b8690b9 100644 (file)
@@ -1,23 +1,39 @@
+include $(top_srcdir)/Makefile.decl
+
 SUBDIRS=Theme
 
-EXTRA_DIST=Makefile.msc
+EXTRA_DIST += Makefile.msc
+
+AM_CPPFLAGS = \
+       -I$(top_srcdir)                 \
+       -I$(top_srcdir)/gdk             \
+       -I$(top_builddir)/gdk           \
+       -DGDK_DISABLE_DEPRECATED        \
+       $(GTK_DEP_CFLAGS)
 
-INCLUDES=$(WIMP_CFLAGS)
 
-enginedir=$(libdir)/gtk-2.0/$(GTK_VERSION)/engines
+LDADDS = \
+       $(top_builddir)/gdk/libgdk-3.la         \
+       $(top_builddir)/gtk/libgtk-3.la         \
+       $(GTK_DEP_LIBS)
+
+enginedir = $(libdir)/gtk-3.0/$(GTK_BINARY_VERSION)/engines
 
 engine_LTLIBRARIES = libwimp.la
 
-libwimp_la_SOURCES =           \
-       wimp_rc_style.c         \
-       wimp_rc_style.h         \
-       wimp_style.c            \
-       wimp_style.h            \
-       wimp_theme_main.c       \
+libwimp_la_SOURCES = \
+       msw_rc_style.c          \
+       msw_rc_style.h          \
+       msw_style.c             \
+       msw_style.h             \
+       msw_theme_main.c        \
        xp_theme.c              \
        xp_theme_defs.h         \
        xp_theme.h
 
-libwimp_la_LDFLAGS = -avoid-version -module -no-undefined -export-dynamic
-libwimp_la_LIBADD= $(WIMP_LIBS)
+libwimp_la_LDFLAGS = \
+       -avoid-version -module -no-undefined -export-dynamic
+
+libwimp_la_LIBADD = $(LDADDS) -lgdi32
 
+-include $(top_srcdir)/git.mk