]> Pileus Git - ~andy/gtk/blobdiff - gtk/Makefile.am
Drop GtkSelectionWindow
[~andy/gtk] / gtk / Makefile.am
index 14163200426288fc31c00c9ee594702d40261fa3..e164c90c95dc09f686dbeb0045bdcc80730f9391 100644 (file)
@@ -16,7 +16,7 @@ else
 GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %s %f"
 endif
 
-SUBDIRS = a11y . tests
+SUBDIRS = a11y native . tests
 
 if HAVE_PAPI_CUPS
 GTK_PRINT_BACKENDS=file,papi,cups
@@ -107,12 +107,12 @@ endif
 libgtkincludedir = $(includedir)/gtk-3.0/gtk
 libadd = \
        $(top_builddir)/gdk/libgdk-3.la \
-       $(top_builddir)/gtk/a11y/libgail.la \
+       $(top_builddir)/gtk/a11y/libgtka11y.la \
        $(GMODULE_LIBS) \
        $(GTK_DEP_LIBS)
 deps = \
        $(top_builddir)/gdk/libgdk-3.la \
-       $(top_builddir)/gtk/a11y/libgail.la
+       $(top_builddir)/gtk/a11y/libgtka11y.la
 
 # libtool stuff: set version and export symbols for resolving
 # since automake doesn't support conditionalized libsomething_la_LDFLAGS
@@ -148,6 +148,7 @@ deprecated_h_sources =                      \
        deprecated/gtkcolorsel.h        \
        deprecated/gtkcolorseldialog.h  \
        deprecated/gtkfontsel.h         \
+       deprecated/gtkgradient.h        \
        deprecated/gtkhandlebox.h       \
        deprecated/gtkhbbox.h           \
        deprecated/gtkhbox.h            \
@@ -156,8 +157,9 @@ deprecated_h_sources =                      \
        deprecated/gtkhscrollbar.h      \
        deprecated/gtkhseparator.h      \
        deprecated/gtkhsv.h             \
-       deprecated/gtkstyle.h           \
        deprecated/gtkrc.h              \
+       deprecated/gtkstyle.h           \
+       deprecated/gtksymboliccolor.h   \
        deprecated/gtktable.h           \
        deprecated/gtktearoffmenuitem.h \
        deprecated/gtkvbbox.h           \
@@ -167,9 +169,14 @@ deprecated_h_sources =                     \
        deprecated/gtkvseparator.h      \
        deprecated/gtkvpaned.h
 
+deprecated_private_h_sources =                 \
+       deprecated/gtkgradientprivate.h         \
+       deprecated/gtksymboliccolorprivate.h
+
 gtk_public_h_sources =                 \
        gtk.h                   \
        gtkx.h                  \
+       gtk-a11y.h              \
        gtkaboutdialog.h        \
        gtkaccelgroup.h         \
        gtkaccellabel.h         \
@@ -249,7 +256,6 @@ gtk_public_h_sources =              \
        gtkfontchooserdialog.h  \
        gtkfontchooserwidget.h  \
        gtkframe.h              \
-       gtkgradient.h           \
        gtkgrid.h               \
        gtkiconfactory.h        \
        gtkicontheme.h          \
@@ -265,12 +271,14 @@ gtk_public_h_sources =            \
        gtkinvisible.h          \
        gtklabel.h              \
        gtklayout.h             \
+       gtklevelbar.h           \
        gtklinkbutton.h         \
        gtkliststore.h          \
        gtklockbutton.h         \
        gtkmain.h               \
        gtkmenu.h               \
        gtkmenubar.h            \
+       gtkmenubutton.h         \
        gtkmenuitem.h           \
        gtkmenushell.h          \
        gtkmenutoolbutton.h     \
@@ -309,6 +317,7 @@ gtk_public_h_sources =              \
        gtkscrollable.h         \
        gtkscrollbar.h          \
        gtkscrolledwindow.h     \
+       gtksearchentry.h        \
        gtkselection.h          \
        gtkseparator.h          \
        gtkseparatormenuitem.h  \
@@ -327,7 +336,6 @@ gtk_public_h_sources =              \
        gtkstyleproperties.h    \
        gtkstyleprovider.h      \
        gtkswitch.h             \
-       gtksymboliccolor.h      \
        gtktestutils.h          \
        gtktextattributes.h     \
        gtktextbuffer.h         \
@@ -391,21 +399,21 @@ gtk_appchooser_impl_c_sources = \
        gtkappchooseronlinepk.c
 endif
 
-gtk_private_type_h_sources = \
-       gtkcsstypesprivate.h
+gtk_private_type_h_sources =   \
+       gtkcsstypesprivate.h    \
+       gtktexthandleprivate.h
 
 
 # GTK+ header files that don't get installed
 gtk_private_h_sources =                \
        gactionmuxer.h          \
-       gsimpleactionobserver.h \
        gactionobserver.h       \
        gactionobservable.h     \
        gtkapplicationprivate.h \
        gtkaccelgroupprivate.h  \
        gtkaccelmapprivate.h    \
+       gtkactionhelper.h       \
        gtkallocatedbitmaskprivate.h    \
-       gtkanimationdescription.h \
        gtkappchooserprivate.h  \
        gtkappchoosermodule.h   \
        gtkappchooseronline.h   \
@@ -414,8 +422,10 @@ gtk_private_h_sources =            \
        gtkbitmaskprivateimpl.h \
        gtkborderimageprivate.h \
        gtkboxprivate.h         \
+       gtkbubblewindowprivate.h        \
        gtkbuilderprivate.h     \
        gtkbuttonprivate.h      \
+       gtkcairoblurprivate.h   \
        gtkcellareaboxcontextprivate.h  \
        gtkcolorswatchprivate.h \
        gtkcoloreditorprivate.h \
@@ -423,7 +433,11 @@ gtk_private_h_sources =            \
        gtkcolorscaleprivate.h  \
        gtkcolorchooserprivate.h        \
        gtkcontainerprivate.h   \
+       gtkcssanimationprivate.h        \
        gtkcssarrayvalueprivate.h       \
+       gtkcssbgsizevalueprivate.h      \
+       gtkcssbordervalueprivate.h      \
+       gtkcsscolorvalueprivate.h       \
        gtkcsscomputedvaluesprivate.h \
        gtkcsscornervalueprivate.h      \
        gtkcsscustompropertyprivate.h \
@@ -434,16 +448,20 @@ gtk_private_h_sources =           \
        gtkcssimagegradientprivate.h    \
        gtkcssimagelinearprivate.h      \
        gtkcssimageprivate.h    \
+       gtkcssimagesurfaceprivate.h     \
        gtkcssimageurlprivate.h \
        gtkcssimagevalueprivate.h       \
        gtkcssimagewin32private.h       \
        gtkcssinheritvalueprivate.h     \
        gtkcssinitialvalueprivate.h     \
+       gtkcsskeyframesprivate.h        \
        gtkcsslookupprivate.h   \
        gtkcssmatcherprivate.h  \
        gtkcssnumbervalueprivate.h      \
        gtkcssparserprivate.h   \
+       gtkcsspositionvalueprivate.h    \
        gtkcssproviderprivate.h \
+       gtkcssrepeatvalueprivate.h      \
        gtkcssrgbavalueprivate.h        \
        gtkcsssectionprivate.h  \
        gtkcssselectorprivate.h \
@@ -453,6 +471,8 @@ gtk_private_h_sources =             \
        gtkcssstringvalueprivate.h      \
        gtkcssstylefuncsprivate.h \
        gtkcssstylepropertyprivate.h \
+       gtkcsstransitionprivate.h       \
+       gtkcsstypedvalueprivate.h       \
        gtkcssvalueprivate.h    \
        gtkcustompaperunixdialog.h \
        gtkentryprivate.h       \
@@ -465,6 +485,7 @@ gtk_private_h_sources =             \
        gtkfilesystemmodel.h    \
        gtkfontchooserprivate.h \
        gtkfontchooserutils.h   \
+       gtkhslaprivate.h        \
        gtkiconcache.h          \
        gtkiconhelperprivate.h  \
        gtkiconviewprivate.h    \
@@ -473,11 +494,12 @@ gtk_private_h_sources =           \
        gtkimcontextsimpleseqs.h \
        gtkintl.h               \
        gtkkeyhash.h            \
+       gtklockbuttonprivate.h  \
+       gtkmenubuttonprivate.h  \
        gtkmenuprivate.h        \
        gtkmenuitemprivate.h    \
        gtkmenushellprivate.h   \
        gtkmnemonichash.h       \
-       gtkmodelmenu.h          \
        gtkmodelmenuitem.h      \
        gtkmodifierstyle.h      \
        gtkmodulesprivate.h     \
@@ -503,16 +525,18 @@ gtk_private_h_sources =           \
        gtkselectionprivate.h   \
        gtksettingsprivate.h    \
        gtksizegroup-private.h  \
+       gtksizerequestcacheprivate.h    \
        gtksocketprivate.h      \
+       gtkstyleanimationprivate.h \
        gtkstylecascadeprivate.h \
        gtkstylecontextprivate.h \
        gtkstylepropertiesprivate.h \
        gtkstylepropertyprivate.h \
        gtkstyleproviderprivate.h \
-       gtksymboliccolorprivate.h \
        gtktextbtree.h          \
        gtktextbufferserialize.h \
        gtktextchildprivate.h   \
+       gtktexthandleprivate.h  \
        gtktextiterprivate.h    \
        gtktextmarkprivate.h    \
        gtktextsegment.h        \
@@ -521,7 +545,6 @@ gtk_private_h_sources =             \
        gtktextutil.h           \
        gtkthemingbackgroundprivate.h \
        gtkthemingengineprivate.h \
-       gtktimeline.h           \
        gtktoolpaletteprivate.h \
        gtktreedatalist.h       \
        gtktreeprivate.h        \
@@ -538,6 +561,7 @@ deprecated_c_sources =                      \
        deprecated/gtkcolorsel.c        \
        deprecated/gtkcolorseldialog.c  \
        deprecated/gtkfontsel.c         \
+       deprecated/gtkgradient.c        \
        deprecated/gtkhandlebox.c       \
        deprecated/gtkhbbox.c           \
        deprecated/gtkhbox.c            \
@@ -548,6 +572,7 @@ deprecated_c_sources =                      \
        deprecated/gtkhsv.c             \
        deprecated/gtkrc.c              \
        deprecated/gtkstyle.c           \
+       deprecated/gtksymboliccolor.c   \
        deprecated/gtktable.c           \
        deprecated/gtktearoffmenuitem.c \
        deprecated/gtkvbbox.c           \
@@ -560,11 +585,11 @@ deprecated_c_sources =                    \
 gtk_base_c_sources =           \
        $(deprecated_c_sources) \
        gactionmuxer.c          \
-       gsimpleactionobserver.c \
        gactionobserver.c       \
        gactionobservable.c     \
        gtkactionable.c         \
        gtkquery.c              \
+       gtksearchentry.c        \
        gtksearchengine.c       \
        gtksearchenginesimple.c \
        fnmatch.c               \
@@ -574,6 +599,7 @@ gtk_base_c_sources =                \
        gtkaccelmap.c           \
        gtkaccessible.c         \
        gtkaction.c             \
+       gtkactionhelper.c       \
        gtkactiongroup.c        \
        gtkactivatable.c        \
        gtkadjustment.c         \
@@ -587,7 +613,6 @@ gtk_base_c_sources =                \
        gtkappchooseronline.c   \
        gtkapplication.c        \
        gtkapplicationwindow.c  \
-       gtkanimationdescription.c \
        gtkarrow.c              \
        gtkaspectframe.c        \
        gtkassistant.c          \
@@ -597,11 +622,13 @@ gtk_base_c_sources =              \
        gtkborder.c             \
        gtkborderimage.c        \
        gtkbox.c                \
+       gtkbubblewindow.c       \
        gtkbuildable.c          \
        gtkbuilder.c            \
        gtkbuilderparser.c      \
        gtkbuilder-menus.c      \
        gtkbutton.c             \
+       gtkcairoblur.c          \
        gtkcalendar.c           \
        gtkcellarea.c           \
        gtkcellareabox.c        \
@@ -633,7 +660,11 @@ gtk_base_c_sources =               \
        gtkcombobox.c           \
        gtkcomboboxtext.c       \
        gtkcontainer.c          \
+       gtkcssanimation.c       \
        gtkcssarrayvalue.c      \
+       gtkcssbgsizevalue.c     \
+       gtkcssbordervalue.c     \
+       gtkcsscolorvalue.c      \
        gtkcsscomputedvalues.c  \
        gtkcsscornervalue.c     \
        gtkcsscustomproperty.c  \
@@ -644,16 +675,20 @@ gtk_base_c_sources =              \
        gtkcssimagecrossfade.c  \
        gtkcssimagegradient.c   \
        gtkcssimagelinear.c     \
+       gtkcssimagesurface.c    \
        gtkcssimageurl.c        \
        gtkcssimagevalue.c      \
        gtkcssimagewin32.c      \
        gtkcssinheritvalue.c    \
        gtkcssinitialvalue.c    \
+       gtkcsskeyframes.c       \
        gtkcsslookup.c          \
        gtkcssmatcher.c         \
        gtkcssnumbervalue.c     \
        gtkcssparser.c          \
+       gtkcsspositionvalue.c   \
        gtkcssprovider.c        \
+       gtkcssrepeatvalue.c     \
        gtkcssrgbavalue.c       \
        gtkcsssection.c         \
        gtkcssselector.c        \
@@ -665,6 +700,8 @@ gtk_base_c_sources =                \
        gtkcssstylefuncs.c      \
        gtkcssstyleproperty.c   \
        gtkcssstylepropertyimpl.c \
+       gtkcsstransition.c      \
+       gtkcsstypedvalue.c      \
        gtkcssvalue.c           \
        gtkcsstypes.c           \
        gtkdialog.c             \
@@ -693,8 +730,8 @@ gtk_base_c_sources =                \
        gtkfontchooserutils.c   \
        gtkfontchooserwidget.c  \
        gtkframe.c              \
-       gtkgradient.c           \
        gtkgrid.c               \
+       gtkhsla.c               \
        gtkiconcache.c          \
        gtkiconcachevalidator.c \
        gtkiconfactory.c        \
@@ -712,6 +749,7 @@ gtk_base_c_sources =                \
        gtkkeyhash.c            \
        gtklabel.c              \
        gtklayout.c             \
+       gtklevelbar.c           \
        gtklinkbutton.c         \
        gtkliststore.c          \
        gtklockbutton.c         \
@@ -719,6 +757,7 @@ gtk_base_c_sources =                \
        gtkmarshalers.c         \
        gtkmenu.c               \
        gtkmenubar.c            \
+       gtkmenubutton.c         \
        gtkmenuitem.c           \
        gtkmenushell.c          \
        gtkmenutoolbutton.c     \
@@ -778,12 +817,14 @@ gtk_base_c_sources =              \
        gtksettings.c           \
        gtksizegroup.c          \
        gtksizerequest.c        \
+       gtksizerequestcache.c   \
        gtkshow.c               \
        gtkspinbutton.c         \
        gtkspinner.c            \
        gtkstatusbar.c          \
        gtkstatusicon.c         \
        gtkstock.c              \
+       gtkstyleanimation.c     \
        gtkstylecascade.c       \
        gtkstylecontext.c       \
        gtkstyleproperties.c    \
@@ -791,7 +832,6 @@ gtk_base_c_sources =                \
        gtkstyleprovider.c      \
        gtkstyleproviderprivate.c       \
        gtkswitch.c             \
-       gtksymboliccolor.c      \
        gtktestutils.c          \
        gtktextattributes.c     \
        gtktextbtree.c          \
@@ -800,6 +840,7 @@ gtk_base_c_sources =                \
        gtktextbufferserialize.c \
        gtktextchild.c          \
        gtktextdisplay.c        \
+       gtktexthandle.c         \
        gtktextiter.c           \
        gtktextlayout.c         \
        gtktextmark.c           \
@@ -811,7 +852,6 @@ gtk_base_c_sources =                \
        gtktextview.c           \
        gtkthemingbackground.c  \
        gtkthemingengine.c      \
-       gtktimeline.c           \
        gtktoggleaction.c       \
        gtktogglebutton.c       \
        gtktoggletoolbutton.c   \
@@ -847,6 +887,15 @@ gtk_base_c_sources =               \
 gtk_c_sources = $(gtk_base_c_sources)
 gtk_all_c_sources = $(gtk_base_c_sources)
 
+gtk_dbus_built_sources = gtkdbusgenerated.c gtkdbusgenerated.h
+
+$(gtk_dbus_built_sources) : Makefile.am gtkdbusinterfaces.xml
+       $(AM_V_GEN) gdbus-codegen \
+       --interface-prefix org.Gtk. \
+       --c-namespace _Gtk \
+       --generate-c-code gtkdbusgenerated \
+       $(srcdir)/gtkdbusinterfaces.xml
+
 gtk_os_unix_c_sources =                \
        gtkcustompaperunixdialog.c      \
        gtkpagesetupunixdialog.c        \
@@ -858,7 +907,8 @@ gtk_os_unix_c_sources =             \
        gtkprintoperation-unix.c        \
        gtkprintunixdialog.c            \
         gtkprintbackend.c              \
-       gtksearchenginetracker.c
+       gtksearchenginetracker.c        \
+       $(gtk_dbus_built_sources)
 gtk_all_c_sources += $(gtk_os_unix_c_sources)
 if OS_UNIX
 gtk_private_h_sources += \
@@ -870,6 +920,8 @@ gtk_private_h_sources += \
        gtkprinteroptionwidget.h        \
        gtksearchenginetracker.h
 gtk_c_sources += $(gtk_os_unix_c_sources)
+else
+gtk_c_sources += $(gtk_dbus_built_sources)
 endif
 
 gtk_os_win32_c_sources = \
@@ -895,34 +947,48 @@ gtk_use_win32_c_sources =         \
 gtk_use_quartz_c_sources =     \
        gtksearchenginequartz.c \
        gtkmountoperation-stub.c \
-  gtkquartz-menu.h \
-  gtkquartz-menu.c \
+       gtkmodelmenu-quartz.c \
        gtkquartz.c
 gtk_use_stub_c_sources =       \
        gtkmountoperation-stub.c
 gtk_all_c_sources += $(gtk_use_x11_c_sources) $(gtk_use_win32_c_sources) $(gtk_use_quartz_c_sources) $(gtk_use_stub_c_sources)
-if USE_X11
-gtk_private_h_sources +=       \
+gtk_use_x11_private_h_sources =        \
        gtkxembed.h             \
        gtktrayicon.h           \
        xembed.h
+if USE_X11
 gtk_c_sources += $(gtk_use_x11_c_sources)
-else
-if USE_WIN32
-gtk_private_h_sources +=       \
+gtk_private_h_sources += $(gtk_use_x11_private_h_sources)
+endif
+
+gtk_use_win32_private_h_sources =      \
        gtkwin32embed.h         \
        gtkwin32embedwidget.h
+if USE_WIN32
 gtk_c_sources += $(gtk_use_win32_c_sources)
-else
-if USE_QUARTZ
-gtk_private_h_sources +=       \
+gtk_private_h_sources += $(gtk_use_win32_private_h_sources)
+endif
+
+gtk_use_quartz_private_h_sources =     \
        gtksearchenginequartz.h \
-       gtkmenuquartz.h \
+       gtkmodelmenu-quartz.h \
        gtkquartz.h
+if USE_QUARTZ
 gtk_c_sources += $(gtk_use_quartz_c_sources)
 libgtk_3_la_CFLAGS = "-xobjective-c"
+gtk_private_h_sources += $(gtk_use_quartz_private_h_sources)
+endif
 
-else
+gtk_all_private_h_sources = \
+       $(deprecated_private_h_sources) \
+       $(gtk_private_h_sources) \
+       $(gtk_use_x11_private_h_sources) \
+       $(gtk_use_win32_private_h_sources) \
+       $(gtk_use_quartz_private_h_sources)
+
+if !USE_X11
+if !USE_WIN32
+if !USE_QUARTZ
 gtk_c_sources += $(gtk_use_stub_c_sources)
 endif
 endif
@@ -959,12 +1025,14 @@ gtk_built_public_sources =                       \
 
 # built headers that don't get installed
 gtk_built_private_headers =                    \
+       gtkdbusgenerated.h                      \
        gtkresources.h                          \
        gtkmarshalers.h                         \
        gtkbuiltincache.h                       \
        gtkprivatetypebuiltins.h
 
 gtk_built_sources =                            \
+       gtkdbusgenerated.c                      \
        gtkresources.c                          \
        gtktypebuiltins.c                       \
        gtktypefuncs.c                          \
@@ -1006,7 +1074,7 @@ MAINTAINERCLEANFILES = \
        stock-icons/icon-theme.cache
 
 EXTRA_HEADERS =
-EXTRA_DIST += $(gtk_private_h_sources) $(gtk_extra_sources)
+EXTRA_DIST += $(gtk_all_private_h_sources) $(gtk_extra_sources)
 EXTRA_DIST += $(gtk_built_sources)
 EXTRA_DIST += $(STOCK_ICONS)
 
@@ -1126,7 +1194,7 @@ endif
 
 if USE_QUARTZ
 install-mac-key-theme:
-       $(mkdir_p) $(DESTDIR)$(datadir)/themes/Mac/gtk-3.0
+       $(MKDIR_P) $(DESTDIR)$(datadir)/themes/Mac/gtk-3.0
        $(INSTALL_DATA) $(srcdir)/gtk-keys.css.mac $(DESTDIR)$(datadir)/themes/Mac/gtk-3.0/gtk-keys.css
 uninstall-mac-key-theme:
        rm -f $(DESTDIR)$(datadir)/themes/Mac/gtk-3.0/gtk-keys.css
@@ -1138,7 +1206,7 @@ endif
 dist-hook: ../build/win32/vs9/gtk.vcproj ../build/win32/vs10/gtk.vcxproj ../build/win32/vs10/gtk.vcxproj.filters
 
 ../build/win32/vs9/gtk.vcproj: ../build/win32/vs9/gtk.vcprojin
-       for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) | tr '/' '\\'`; do \
+       for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) $(gtk_dbus_built_sources) | tr '/' '\\'`; do \
                case $$F in \
                *.c) echo '   <File RelativePath="..\..\..\gtk\'$$F'" />' \
                     ;; \
@@ -1148,7 +1216,7 @@ dist-hook: ../build/win32/vs9/gtk.vcproj ../build/win32/vs10/gtk.vcxproj ../buil
        rm libgtk.sourcefiles
 
 ../build/win32/vs10/gtk.vcxproj: ../build/win32/vs10/gtk.vcxprojin
-       for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) | tr '/' '\\'`; do \
+       for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) $(gtk_dbus_built_sources) | tr '/' '\\'`; do \
                case $$F in \
                *.c) echo '   <ClCompile Include="..\..\..\gtk\'$$F'" />' \
                     ;; \
@@ -1169,9 +1237,9 @@ dist-hook: ../build/win32/vs9/gtk.vcproj ../build/win32/vs10/gtk.vcxproj ../buil
 
 # Install a RC file for the default GTK+ theme, and key themes
 install-data-local: install-ms-lib install-def-file install-mac-key-theme
-       $(mkdir_p) $(DESTDIR)$(datadir)/themes/Default/gtk-3.0
+       $(MKDIR_P) $(DESTDIR)$(datadir)/themes/Default/gtk-3.0
        $(INSTALL_DATA) $(srcdir)/gtk-keys.css.default $(DESTDIR)$(datadir)/themes/Default/gtk-3.0/gtk-keys.css
-       $(mkdir_p) $(DESTDIR)$(datadir)/themes/Emacs/gtk-3.0
+       $(MKDIR_P) $(DESTDIR)$(datadir)/themes/Emacs/gtk-3.0
        $(INSTALL_DATA) $(srcdir)/gtk-keys.css.emacs $(DESTDIR)$(datadir)/themes/Emacs/gtk-3.0/gtk-keys.css
 
 uninstall-local: uninstall-ms-lib uninstall-def-file uninstall-mac-key-theme
@@ -1240,8 +1308,7 @@ endif
 #
 # Installed tools
 #
-bin_PROGRAMS = \
-       gtk-query-immodules-3.0
+bin_PROGRAMS = gtk-query-immodules-3.0
 
 if BUILD_ICON_CACHE
 bin_PROGRAMS += gtk-update-icon-cache
@@ -1288,6 +1355,12 @@ gtk_update_icon_cache_LDADD = $(GDK_PIXBUF_LIBS)
 gtk_update_icon_cache_SOURCES = updateiconcache.c
 endif
 
+if HAVE_GIO_UNIX
+bin_PROGRAMS += gtk-launch
+gtk_launch_LDADD = $(LDADDS)
+gtk_launch_SOURCES = gtk-launch.c
+endif
+
 .PHONY: files test test-debug
 
 files:
@@ -1586,12 +1659,20 @@ stamp-icons: $(STOCK_ICONS)
 if USE_EXTERNAL_ICON_CACHE
 gtk_update_icon_cache_program = $(GTK_UPDATE_ICON_CACHE)
 else
-gtk_update_icon_cache_program = ./gtk-update-icon-cache
+if CROSS_COMPILING
+gtk_update_icon_cache_program = ./native/native-update-icon-cache
+else
+gtk_update_icon_cache_program = ./gtk-update-icon-cache$(EXEEXT)
+endif
 endif
 
 gtkbuiltincache.h: @REBUILD@ stamp-icons
 if !USE_EXTERNAL_ICON_CACHE
-       $(AM_V_at) $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT) $(GTK_UPDATE_ICON_CACHE_MANIFEST)
+if CROSS_COMPILING
+       $(AM_V_at) $(MAKE) $(AM_MAKEFLAGS) -C native/
+else
+       $(AM_V_at) $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
+endif
 endif
        $(AM_V_GEN) $(gtk_update_icon_cache_program) --quiet --force --ignore-theme-index               \
           --source builtin_icons stock-icons > gtkbuiltincache.h.tmp &&        \
@@ -1611,6 +1692,7 @@ EXTRA_DIST +=                   \
        gtkprint-win32.c        \
        gtksearchenginequartz.h \
        gtk.gresource.xml       \
+       gtkdbusinterfaces.xml   \
        gtk-default.css         \
        gtk-keys.css.default    \
        gtk-keys.css.emacs      \