]> Pileus Git - ~andy/gtk/blobdiff - gtk/Makefile.am
Merge branch 'native-layout-incubator'
[~andy/gtk] / gtk / Makefile.am
index 5ecf7301d4e5ba67972bd5c82c2e9e932183fdd7..ce39a1c6b4d2726b2cd169203ed07f24d55a2a0d 100644 (file)
@@ -648,9 +648,9 @@ gtk_public_h_sources += \
        gtkclist.h              \
        gtkcombo.h              \
        gtkctree.h              \
-       gtkcurve.h              \
+       gtkcurve.h              \
        gtkfilesel.h            \
-       gtkgamma.h              \
+       gtkgamma.h              \
        gtkinputdialog.h        \
        gtkitemfactory.h        \
        gtklist.h               \
@@ -945,6 +945,18 @@ install-mac-key-theme:
 uninstall-mac-key-theme:
 endif
 
+dist-hook: ../build/win32/vs9/gtk.vcproj
+
+../build/win32/vs9/gtk.vcproj: ../build/win32/vs9/gtk.vcprojin
+       for F in $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources); do \
+               case $$F in \
+               *.c) echo '   <File RelativePath="..\..\..\gtk\'$$F'" />' \
+                    ;; \
+               esac; \
+       done >libgtk.sourcefiles
+       $(CPP) -P - <$(top_srcdir)/build/win32/vs9/gtk.vcprojin >$@
+       rm libgtk.sourcefiles
+
 # Install a RC file for the default GTK+ theme, and key themes
 install-data-local: install-ms-lib install-def-file install-mac-key-theme
        $(mkinstalldirs) $(DESTDIR)$(datadir)/themes/Raleigh/gtk-2.0