]> Pileus Git - grits/blobdiff - src/plugins/Makefile.am
Add version info for Debian
[grits] / src / plugins / Makefile.am
index 87b74f1251ce286451562e2265033b340679793b..d18b9e90180cf4f51f1daf89a0c6e383ceabe2ca 100644 (file)
@@ -1,18 +1,23 @@
-AM_CFLAGS   = -Wall --std=gnu99  -I../
+MAINTAINERCLEANFILES = Makefile.in
+
+AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
 AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version
-LIBS        = $(top_srcdir)/src/gis/libgis.la
+AM_LDFLAGS  = -module -avoid-version -no-undefined
+LIBS        = $(top_srcdir)/src/libgis.la
 
-plugindir = $(libdir)/gis
+pluginsdir  = "$(libdir)/$(GIS_SUBDIR)"
 
-plugin_LTLIBRARIES =
+plugins_LTLIBRARIES = sat.la elev.la map.la env.la test.la
+sat_la_SOURCES      = sat.c  sat.h
+elev_la_SOURCES     = elev.c elev.h
+map_la_SOURCES      = map.c  map.h
+env_la_SOURCES      = env.c  env.h
+test_la_SOURCES     = test.c test.h
 
-if HAVE_RSL
-plugin_LTLIBRARIES += radar.la
-radar_la_SOURCES = radar.c   radar.h \
-       marching.c marching.h \
-       radar-colormap.c
-radar_la_LDFLAGS = $(AM_LDFLAGS) $(RSL_LIBS)
-endif
+noinst_LTLIBRARIES  = teapot.la
+teapot_la_SOURCES   = \
+       $(top_srcdir)/examples/plugin/teapot.c \
+       $(top_srcdir)/examples/plugin/teapot.h
 
-MAINTAINERCLEANFILES = Makefile.in
+test:
+       ( cd ../; make test )