]> Pileus Git - grits/blobdiff - src/Makefile.am
Win32 port
[grits] / src / Makefile.am
index 1721d9f249ce07a00cdb7620a86b72fe89598e13..17c04a603b300a3fc615e724ce83e2646802d71b 100644 (file)
@@ -1,48 +1,94 @@
-AM_LDFLAGS    = $(RSL_LIBS) $(GTK_LIBS)
-AM_CFLAGS     = -Wall -Werror -Wno-unused --std=gnu99 
-bin_PROGRAMS  = aweather wsr88ddec
-
-BUILT_SOURCES = marshal.c marshal.h
-
-aweather_SOURCES  = main.c \
-       marshal.c         marshal.h         \
-       aweather-gui.c    aweather-gui.h    \
-       aweather-view.c   aweather-view.h   \
-       aweather-plugin.c aweather-plugin.h \
-       data.c            data.h            \
-       location.c        location.h        \
-       plugin-radar.c    plugin-radar.h    \
-       plugin-radar-colormap.c             \
-       plugin-ridge.c    plugin-ridge.h    \
-       plugin-example.c  plugin-example.h
-aweather_CPPFLAGS = $(RSL_CFLAGS) $(GTK_CFLAGS) -DDATADIR="\"$(datadir)\"" 
-
-wsr88ddec         = wsr88ddec.c
-wsr88ddec_LDADD   = -lbz2
-
-CLEANFILES = gmon.out valgrind.out
+SUBDIRS = data objects . plugins
+
+AM_CFLAGS   = -Wall --std=gnu99 -I$(top_srcdir)/src
+AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
+AM_LDADD    = $(GLIB_LIBS) $(GTK_LIBS) $(SOUP_LIBS)
+AM_LDFLAGS  = --as-needed -no-undefined
+
+BUILT_SOURCES = gis-marshal.c gis-marshal.h
+
+
+# Headers
+gis_includedir = $(includedir)/gis
+gis_include_HEADERS = \
+       gis.h         \
+       gis-viewer.h  \
+       gis-prefs.h   \
+       gis-opengl.h  \
+       gis-plugin.h  \
+       gis-util.h    \
+       gpqueue.h     \
+       roam.h
+
+# Pkg-config
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libgis.pc
+
+# Library
+lib_LTLIBRARIES = libgis.la
+
+libgis_la_SOURCES = gis.h \
+       gis-viewer.c  gis-viewer.h  \
+       gis-prefs.c   gis-prefs.h   \
+       gis-opengl.c  gis-opengl.h  \
+       gis-plugin.c  gis-plugin.h  \
+       gis-marshal.c gis-marshal.h \
+       gis-util.c    gis-util.h    \
+       roam.c        roam.h        \
+       gpqueue.c     gpqueue.h
+libgis_la_CPPFLAGS = $(AM_CPPFLAGS) \
+       -DPKGDATADIR="\"$(datadir)/gis\"" \
+       -DPLUGINSDIR="\"$(libdir)/gis\""
+libgis_la_LIBADD  = $(AM_LDADD) \
+       objects/libgis-objects.la \
+       data/libgis-data.la
+
+# Demo program
+if NOTWIN32
+AM_LDFLAGS += -static
+endif
+
+bin_PROGRAMS = gis-demo
+
+gis_demo_SOURCES  = gis-demo.c
+gis_demo_LDADD    = $(AM_LDADD) libgis.la
+
+# Test programs
+noinst_PROGRAMS = gis-test tile-test
+
+gis_test_SOURCES = gis-test.c
+gis_test_LDADD   = $(AM_LDADD) libgis.la
+
+tile_test_SOURCES = tile-test.c
+tile_test_LDADD   = $(AM_LDADD) libgis.la
+
+
 MAINTAINERCLEANFILES = Makefile.in
 
 .list.c:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --body   $< > $@
+       glib-genmarshal --prefix=gis_cclosure_marshal --body   $< > $@
 .list.h:
-       glib-genmarshal --prefix=aweather_cclosure_marshal --header $< > $@
+       glib-genmarshal --prefix=gis_cclosure_marshal --header $< > $@
+
+test: all .libs/gis
+       ./gis-test
 
-test: all
-       ./aweather -d 7
+gdb: all .libs/gis
+       gdb ./gis-test
 
-gdb: all
-       gdb ./aweather
+ddd: all .libs/gis
+       ddd ./gis-test
 
-ddd: all
-       ddd ./aweather
+.libs/gis: plugins/.libs
+       ln -sf ../plugins/.libs .libs/gis
 
-memcheck:
+memcheck: all
        G_SLICE=always-malloc                   \
        G_DEBUG=gc-friendly,resident-modules    \
-       valgrind --leak-check=full              \
+       valgrind --track-origins=yes            \
+                --leak-check=full              \
                 --leak-resolution=high         \
                 --num-callers=50               \
                 --suppressions=gtk.suppression \
-                ./aweather                     \
+                ./gis-test                     \
        2> valgrind.out