]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Remove marching code (now in marching branch)
[aweather] / src / plugins / Makefile.am
index 52a7840ad918f537b199425d803daed7f7f684a9..cf4029a75607fcde2068f866b86382c7a6664828 100644 (file)
@@ -1,17 +1,21 @@
 AM_CFLAGS   = -Wall --std=gnu99  -I../
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version
+AM_CPPFLAGS = $(GIS_CFLAGS)
+AM_LDFLAGS  = -module -avoid-version -no-undefined
+LIBS        = $(GIS_LIBS)
 
-plugindir = $(libdir)/gis
+pluginsdir  = $(pkglibdir)
 
-plugin_LTLIBRARIES =
+plugins_LTLIBRARIES =
 
 if HAVE_RSL
-plugin_LTLIBRARIES += radar.la
+plugins_LTLIBRARIES += radar.la
 radar_la_SOURCES = radar.c   radar.h \
-       marching.c marching.h \
-       radar-colormap.c
-radar_la_LIBADD  = $(RSL_LIBS)
+       radar-colormap.c \
+       ../aweather-location.c
+radar_la_LDFLAGS = $(AM_LDFLAGS) $(RSL_LIBS)
 endif
 
+test:
+       ( cd ../; make test )
+
 MAINTAINERCLEANFILES = Makefile.in