]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Misc Grits/formatting updates
[aweather] / src / plugins / Makefile.am
index 7540ecaae6a6767a1016b54f4aca5f0053e381c2..ce9f557551f3d6ce891017943f9c707c5aafb0ac 100644 (file)
@@ -1,6 +1,7 @@
-AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
 AM_LDFLAGS  = -module -avoid-version -no-undefined
+LIBS        = $(GRITS_LIBS)
 
 pluginsdir  = $(pkglibdir)
 
@@ -12,8 +13,10 @@ radar_la_SOURCES = \
        radar.c  radar.h \
        level2.c level2.h \
        ../aweather-colormap.c \
-       ../aweather-location.c
-radar_la_LIBADD  = $(RSL_LIBS) $(GIS_LIBS) \
+       ../aweather-colormap.h \
+       ../aweather-location.c \
+       ../aweather-location.h
+radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
                   $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 endif