]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Win32 port (and gnulib)
[aweather] / src / plugins / Makefile.am
index cf4029a75607fcde2068f866b86382c7a6664828..be1352430be8d7aa5b700f0fe896ebf3acf73560 100644 (file)
@@ -1,5 +1,5 @@
-AM_CFLAGS   = -Wall --std=gnu99  -I../
-AM_CPPFLAGS = $(GIS_CFLAGS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
 AM_LDFLAGS  = -module -avoid-version -no-undefined
 LIBS        = $(GIS_LIBS)
 
@@ -9,9 +9,12 @@ plugins_LTLIBRARIES =
 
 if HAVE_RSL
 plugins_LTLIBRARIES += radar.la
-radar_la_SOURCES = radar.c   radar.h \
-       radar-colormap.c \
+radar_la_SOURCES = \
+       radar.c  radar.h \
+       level2.c level2.h \
+       ../aweather-colormap.c \
        ../aweather-location.c
+radar_la_LIBADD  = $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 radar_la_LDFLAGS = $(AM_LDFLAGS) $(RSL_LIBS)
 endif