]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Win32 port (and gnulib)
[aweather] / src / plugins / Makefile.am
index 87b74f1251ce286451562e2265033b340679793b..be1352430be8d7aa5b700f0fe896ebf3acf73560 100644 (file)
@@ -1,18 +1,24 @@
-AM_CFLAGS   = -Wall --std=gnu99  -I../
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version
-LIBS        = $(top_srcdir)/src/gis/libgis.la
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
+AM_LDFLAGS  = -module -avoid-version -no-undefined
+LIBS        = $(GIS_LIBS)
 
-plugindir = $(libdir)/gis
+pluginsdir  = $(pkglibdir)
 
-plugin_LTLIBRARIES =
+plugins_LTLIBRARIES =
 
 if HAVE_RSL
-plugin_LTLIBRARIES += radar.la
-radar_la_SOURCES = radar.c   radar.h \
-       marching.c marching.h \
-       radar-colormap.c
+plugins_LTLIBRARIES += radar.la
+radar_la_SOURCES = \
+       radar.c  radar.h \
+       level2.c level2.h \
+       ../aweather-colormap.c \
+       ../aweather-location.c
+radar_la_LIBADD  = $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 radar_la_LDFLAGS = $(AM_LDFLAGS) $(RSL_LIBS)
 endif
 
+test:
+       ( cd ../; make test )
+
 MAINTAINERCLEANFILES = Makefile.in