]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
OSX port
[aweather] / src / plugins / Makefile.am
index 912bb46160111adc5a4ef675c0fa291de5f8bb3c..b873d1b34ea3d0859e54f41805c6e30809d12e1e 100644 (file)
@@ -1,8 +1,16 @@
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
-AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+AM_LDFLAGS  = -shared -module -avoid-version
 LIBS        = $(GRITS_LIBS)
 
+if SYS_WIN
+AM_LDFLAGS += -no-undefined
+dots = ..
+endif
+if !SYS_MAC
+AM_LDFLAGS += -Wl,--as-needed
+endif
+
 pluginsdir  = $(pkglibdir)
 
 plugins_LTLIBRARIES = alert.la
@@ -28,11 +36,6 @@ radar_la_CPPFLAGS = \
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif
 
-if WIN32
-AM_LDFLAGS += -no-undefined
-dots = ..
-endif
-
 test:
        ( cd ../; make test )