]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Update docs
[aweather] / src / plugins / Makefile.am
index b873d1b34ea3d0859e54f41805c6e30809d12e1e..ae72af181aa334c4fb3c4cd4cd16ddcba0ea1c1d 100644 (file)
@@ -5,7 +5,6 @@ LIBS        = $(GRITS_LIBS)
 
 if SYS_WIN
 AM_LDFLAGS += -no-undefined
-dots = ..
 endif
 if !SYS_MAC
 AM_LDFLAGS += -Wl,--as-needed
@@ -19,9 +18,19 @@ alert_la_SOURCES = \
        alert.c      alert.h \
        alert-info.c alert-info.h
 alert_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\""
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\""
 alert_la_LIBADD  = $(GRITS_LIBS)
 
+if HAVE_GPSD
+plugins_LTLIBRARIES += gps.la
+gps_la_SOURCES = \
+       gps-plugin.c      gps-plugin.h
+gps_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src
+gps_la_LIBADD  = $(GPSD_LIBS) $(GRITS_LIBS)
+endif
+
 if HAVE_RSL
 plugins_LTLIBRARIES += radar.la
 radar_la_SOURCES = \
@@ -31,7 +40,7 @@ radar_la_SOURCES = \
        ../aweather-location.c \
        ../aweather-location.h
 radar_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
        -I$(top_srcdir)/src
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif