]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Additional code review feedback and minor UI tweaks.
[aweather] / src / plugins / Makefile.am
index 55166a05e72d011c627a2d4eec59f7ac4f7a4721..ae72af181aa334c4fb3c4cd4cd16ddcba0ea1c1d 100644 (file)
@@ -1,8 +1,15 @@
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
-AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+AM_LDFLAGS  = -shared -module -avoid-version
 LIBS        = $(GRITS_LIBS)
 
+if SYS_WIN
+AM_LDFLAGS += -no-undefined
+endif
+if !SYS_MAC
+AM_LDFLAGS += -Wl,--as-needed
+endif
+
 pluginsdir  = $(pkglibdir)
 
 plugins_LTLIBRARIES = alert.la
@@ -11,10 +18,18 @@ alert_la_SOURCES = \
        alert.c      alert.h \
        alert-info.c alert-info.h
 alert_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
-       -I$(top_srcdir)/lib
-alert_la_LIBADD  = $(GRITS_LIBS) \
-                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\""
+alert_la_LIBADD  = $(GRITS_LIBS)
+
+if HAVE_GPSD
+plugins_LTLIBRARIES += gps.la
+gps_la_SOURCES = \
+       gps-plugin.c      gps-plugin.h
+gps_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src
+gps_la_LIBADD  = $(GPSD_LIBS) $(GRITS_LIBS)
+endif
 
 if HAVE_RSL
 plugins_LTLIBRARIES += radar.la
@@ -25,15 +40,9 @@ radar_la_SOURCES = \
        ../aweather-location.c \
        ../aweather-location.h
 radar_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
-       -I$(top_srcdir)/src -I$(top_srcdir)/lib
-radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
-                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
-endif
-
-if WIN32
-AM_LDFLAGS += -no-undefined
-dots = ..
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src
+radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif
 
 test: