]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
libgis -> grits: Update everything
[aweather] / src / plugins / Makefile.am
index 7a0c4be29e1c1993f72ca9d9cf2afc096ccb36db..83a4e8257e11ba3541db923d1ea6c37697e1b60b 100644 (file)
@@ -1,29 +1,25 @@
-AM_CFLAGS   = -Wall -Werror -Wno-unused --std=gnu99  -I../
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS)
-AM_LDFLAGS  = -module $(GLIB_LIBS) $(GTK_LIBS)
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
+AM_LDFLAGS  = -module -avoid-version -no-undefined
 
-plugindir = $(libdir)/aweather
+pluginsdir  = $(pkglibdir)
 
-plugin_LTLIBRARIES = \
-       example.la \
-       radar.la   \
-       ridge.la
-
-example_la_SOURCES = \
-       example.c \
-       example.h
-example_la_CPPFLAGS = $(AM_CPPFLAGS) $(SOUP_CFLAGS)
-
-ridge_la_SOURCES = \
-       ridge.c \
-       ridge.h
-ridge_la_CPPFLAGS = $(AM_CPPFLAGS) $(SOUP_CFLAGS)
+plugins_LTLIBRARIES =
 
+if HAVE_RSL
+plugins_LTLIBRARIES += radar.la
 radar_la_SOURCES = \
-       radar.c \
-       radar.h \
-       radar-colormap.c
-radar_la_CPPFLAGS = $(AM_CPPFLAGS) $(SOUP_CFLAGS) $(RSL_CFLAGS)
-radar_la_LIBADD = $(SOUP_LIBS) $(RSL_LIBS)
+       radar.c  radar.h \
+       level2.c level2.h \
+       ../aweather-colormap.c \
+       ../aweather-colormap.h \
+       ../aweather-location.c \
+       ../aweather-location.h
+radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
+                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
+endif
+
+test:
+       ( cd ../; make test )
 
 MAINTAINERCLEANFILES = Makefile.in