]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Improve support for relative search paths
[aweather] / src / plugins / Makefile.am
index b873d1b34ea3d0859e54f41805c6e30809d12e1e..7cc1b810611d7d3a8bfe8053fcb10679c94eb8e6 100644 (file)
@@ -5,7 +5,6 @@ LIBS        = $(GRITS_LIBS)
 
 if SYS_WIN
 AM_LDFLAGS += -no-undefined
-dots = ..
 endif
 if !SYS_MAC
 AM_LDFLAGS += -Wl,--as-needed
@@ -19,7 +18,7 @@ alert_la_SOURCES = \
        alert.c      alert.h \
        alert-info.c alert-info.h
 alert_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\""
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\""
 alert_la_LIBADD  = $(GRITS_LIBS)
 
 if HAVE_RSL
@@ -31,7 +30,7 @@ radar_la_SOURCES = \
        ../aweather-location.c \
        ../aweather-location.h
 radar_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
        -I$(top_srcdir)/src
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif