]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Improve support for relative search paths
[aweather] / src / plugins / Makefile.am
index 912bb46160111adc5a4ef675c0fa291de5f8bb3c..7cc1b810611d7d3a8bfe8053fcb10679c94eb8e6 100644 (file)
@@ -1,8 +1,15 @@
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
-AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+AM_LDFLAGS  = -shared -module -avoid-version
 LIBS        = $(GRITS_LIBS)
 
+if SYS_WIN
+AM_LDFLAGS += -no-undefined
+endif
+if !SYS_MAC
+AM_LDFLAGS += -Wl,--as-needed
+endif
+
 pluginsdir  = $(pkglibdir)
 
 plugins_LTLIBRARIES = alert.la
@@ -11,7 +18,7 @@ alert_la_SOURCES = \
        alert.c      alert.h \
        alert-info.c alert-info.h
 alert_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\""
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\""
 alert_la_LIBADD  = $(GRITS_LIBS)
 
 if HAVE_RSL
@@ -23,16 +30,11 @@ radar_la_SOURCES = \
        ../aweather-location.c \
        ../aweather-location.h
 radar_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
        -I$(top_srcdir)/src
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif
 
-if WIN32
-AM_LDFLAGS += -no-undefined
-dots = ..
-endif
-
 test:
        ( cd ../; make test )