]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Win32 fixes and improvements
[aweather] / src / plugins / Makefile.am
index 52a7840ad918f537b199425d803daed7f7f684a9..7540ecaae6a6767a1016b54f4aca5f0053e381c2 100644 (file)
@@ -1,17 +1,23 @@
-AM_CFLAGS   = -Wall --std=gnu99  -I../
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version
+AM_CFLAGS   = -Wall --std=gnu99 $(GIS_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
+AM_LDFLAGS  = -module -avoid-version -no-undefined
 
-plugindir = $(libdir)/gis
+pluginsdir  = $(pkglibdir)
 
-plugin_LTLIBRARIES =
+plugins_LTLIBRARIES =
 
 if HAVE_RSL
-plugin_LTLIBRARIES += radar.la
-radar_la_SOURCES = radar.c   radar.h \
-       marching.c marching.h \
-       radar-colormap.c
-radar_la_LIBADD  = $(RSL_LIBS)
+plugins_LTLIBRARIES += radar.la
+radar_la_SOURCES = \
+       radar.c  radar.h \
+       level2.c level2.h \
+       ../aweather-colormap.c \
+       ../aweather-location.c
+radar_la_LIBADD  = $(RSL_LIBS) $(GIS_LIBS) \
+                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 endif
 
+test:
+       ( cd ../; make test )
+
 MAINTAINERCLEANFILES = Makefile.in