]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Initial checkin of prototype gps plugin support.
[aweather] / src / plugins / Makefile.am
index 83a4e8257e11ba3541db923d1ea6c37697e1b60b..691f7fb5c05e26e58abfff7d1e932c2145b17f33 100644 (file)
@@ -1,22 +1,48 @@
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
-AM_LDFLAGS  = -module -avoid-version -no-undefined
+AM_LDFLAGS  = -shared -module -avoid-version
+LIBS        = $(GRITS_LIBS)
+
+if SYS_WIN
+AM_LDFLAGS += -no-undefined
+endif
+if !SYS_MAC
+AM_LDFLAGS += -Wl,--as-needed
+endif
 
 pluginsdir  = $(pkglibdir)
 
-plugins_LTLIBRARIES =
+plugins_LTLIBRARIES = alert.la
+
+alert_la_SOURCES = \
+       alert.c      alert.h \
+       alert-info.c alert-info.h
+alert_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\""
+alert_la_LIBADD  = $(GRITS_LIBS)
+
+if HAVE_GPSD
+plugins_LTLIBRARIES += gps.la
+gps_la_SOURCES = \
+       gps-plugin.c      gps-plugin.h
+gps_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src
+gps_la_LIBADD  = $(GPS_LIBS) $(GRITS_LIBS)
+endif
 
 if HAVE_RSL
 plugins_LTLIBRARIES += radar.la
 radar_la_SOURCES = \
-       radar.c  radar.h \
-       level2.c level2.h \
-       ../aweather-colormap.c \
-       ../aweather-colormap.h \
+       radar.c      radar.h \
+       level2.c     level2.h \
+       radar-info.c radar-info.h \
        ../aweather-location.c \
        ../aweather-location.h
-radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
-                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
+radar_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(DOTS)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src
+radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS)
 endif
 
 test: