]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Add -no-undefined for win32 build
[aweather] / src / plugins / Makefile.am
index ce9f557551f3d6ce891017943f9c707c5aafb0ac..502bb260fa7471b5a389bf8a04f28a9c32f85d4b 100644 (file)
@@ -1,6 +1,6 @@
 AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
-AM_LDFLAGS  = -module -avoid-version -no-undefined
+AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
 LIBS        = $(GRITS_LIBS)
 
 pluginsdir  = $(pkglibdir)
@@ -10,16 +10,23 @@ plugins_LTLIBRARIES =
 if HAVE_RSL
 plugins_LTLIBRARIES += radar.la
 radar_la_SOURCES = \
-       radar.c  radar.h \
-       level2.c level2.h \
-       ../aweather-colormap.c \
-       ../aweather-colormap.h \
+       radar.c      radar.h \
+       level2.c     level2.h \
+       radar-info.c radar-info.h \
        ../aweather-location.c \
        ../aweather-location.h
+radar_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src -I$(top_srcdir)/lib
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
                   $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 endif
 
+if WIN32
+AM_LDFLAGS += -no-undefined
+dots = ..
+endif
+
 test:
        ( cd ../; make test )