]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Add -no-undefined for win32 build
[aweather] / src / plugins / Makefile.am
index 87b74f1251ce286451562e2265033b340679793b..502bb260fa7471b5a389bf8a04f28a9c32f85d4b 100644 (file)
@@ -1,18 +1,33 @@
-AM_CFLAGS   = -Wall --std=gnu99  -I../
-AM_CPPFLAGS = $(GLIB_CFLAGS) $(GTK_CFLAGS) $(SOUP_CFLAGS)
-AM_LDFLAGS  = -module -avoid-version
-LIBS        = $(top_srcdir)/src/gis/libgis.la
+AM_CFLAGS   = -Wall --std=gnu99 $(GRITS_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/lib
+AM_LDFLAGS  = -shared -module -avoid-version -Wl,--as-needed
+LIBS        = $(GRITS_LIBS)
 
-plugindir = $(libdir)/gis
+pluginsdir  = $(pkglibdir)
 
-plugin_LTLIBRARIES =
+plugins_LTLIBRARIES =
 
 if HAVE_RSL
-plugin_LTLIBRARIES += radar.la
-radar_la_SOURCES = radar.c   radar.h \
-       marching.c marching.h \
-       radar-colormap.c
-radar_la_LDFLAGS = $(AM_LDFLAGS) $(RSL_LIBS)
+plugins_LTLIBRARIES += radar.la
+radar_la_SOURCES = \
+       radar.c      radar.h \
+       level2.c     level2.h \
+       radar-info.c radar-info.h \
+       ../aweather-location.c \
+       ../aweather-location.h
+radar_la_CPPFLAGS = \
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src -I$(top_srcdir)/lib
+radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
+                  $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 endif
 
+if WIN32
+AM_LDFLAGS += -no-undefined
+dots = ..
+endif
+
+test:
+       ( cd ../; make test )
+
 MAINTAINERCLEANFILES = Makefile.in