]> Pileus Git - aweather/blobdiff - src/plugins/Makefile.am
Misc win32 fixes
[aweather] / src / plugins / Makefile.am
index 9755b8c66cb180e9d0df7661d3c5208c81755814..9fe42ae02e40999b00a58974531a908cb2bf89c8 100644 (file)
@@ -16,11 +16,16 @@ radar_la_SOURCES = \
        ../aweather-location.c \
        ../aweather-location.h
 radar_la_CPPFLAGS = \
-       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\""
+       -DPKGDATADIR="\"$(dots)$(pkgdatadir)\"" \
+       -I$(top_srcdir)/src -I$(top_srcdir)/lib
 radar_la_LIBADD  = $(RSL_LIBS) $(GRITS_LIBS) \
                   $(addprefix $(top_srcdir)/lib/,$(gl_LTLIBOBJS))
 endif
 
+if WIN32
+dots = ..
+endif
+
 test:
        ( cd ../; make test )