]> Pileus Git - aweather/blobdiff - src/Makefile.am
Remove gnulib, it's a huge pain
[aweather] / src / Makefile.am
index d3861ebfe9c8a9bb72ae79476ac5d4101dda6791..fb2e6f5e4cc42e34a9a4a5f9e21fd8635fbadd8c 100644 (file)
@@ -26,7 +26,6 @@ wsr88ddec_LDFLAGS     = -mwindows
 aweather_SOURCES     += resource.rc
 aweather_LDFLAGS      = -mwindows
 aweather_CPPFLAGS    += -I$(top_srcdir)/lib
-aweather_LDADD       += $(top_srcdir)/lib/libgnu.la
 
 bin_PROGRAMS         += aweather-dbg
 aweather_dbg_SOURCES  = $(aweather_SOURCES)
@@ -34,7 +33,7 @@ aweather_dbg_CPPFLAGS = $(aweather_CPPFLAGS)
 aweather_dbg_LDADD    = $(aweather_LDADD)
 endif
 
-.rc.o: ../data/aweather.ico
+.rc.o: ../data/icons/48x48/aweather.ico
        $(RC) -o $@ $<
 
 CLEANFILES = gmon.out valgrind.out
@@ -51,3 +50,15 @@ gdb: all
 
 ddd: all
        ddd .libs/aweather
+
+memcheck: all
+       G_SLICE=always-malloc                   \
+       G_DEBUG=gc-friendly,resident-modules    \
+       valgrind --track-origins=yes            \
+                --leak-check=full              \
+                --leak-resolution=high         \
+                --num-callers=50               \
+                --suppressions=gtk.suppression \
+                --suppressions=/usr/lib/valgrind/default.supp \
+                .libs/aweather                 \
+       2> valgrind.out